XCode6 + iOS 8.1 + OF 0.8.4 + OSX 10.10 don't build

Anyone is having success building an iOS app with this configuration?

I’m facing this for almost 30 days, with a lot build errors, and don’t running the simulator…

Any suggestions or help?

Thks, in advance

Have the same issue. Existing app no longer builds. Multiple semantic issues. Did you find a solution?

It’s working here the same setup. All up to date. Anyways is working on my iPad with my iOS dev license, but not into iOS simulators. I though the iOS simulators problems was a conflict with the license or something…

I tried to build with the github OF repo, and now is not working anymore. Some weeks ago was working fine, except with the ofxOSC addon it wasn’t working.

@moebiussurfing did you mean the OF’s master version from github? I was planning to test tomorrow, thanks for the advice.

No, now I am using 0.8.4, where it’s working fine.
With the github repo I updated today and all the iOS examples are not working anymore.
(EDIT: neither the project generator to generate the example projects for iOS & OS X.)

Anyway, you can have both versions (0.8.4 iOS, 0.8.4 OS X & Github) on a different folder.

You haven’t specified WHAT are the build errors, but I’m willing to bet this will help:

I had the exact problem (building on device, failing on simulator) and the solution suggested worked perfectly.


Until oF 0.9 release use this function in your main.mm (place above the main function).

extern "C"{
size_t fwrite$UNIX2003( const void *a, size_t b, size_t c, FILE *d )
return fwrite(a, b, c, d);
char* strerror$UNIX2003( int errnum )
return strerror(errnum);
time_t mktime$UNIX2003(struct tm * a)
return mktime(a);
double strtod$UNIX2003(const char * a, char ** b) {
return strtod(a, b);
1 Like