xCode4 - enable to rename a project

Hi,

I’m enable to rename an openframeworks xcode project in xCode4. I tried different ways to do it.

If I use xCode4 to rename my project I get the following error:

  
  
fatal: source directory is empty, source=apps/dptDev/emptyExample/emptyExample.xcodeproj, destination=apps/dptDev/emptyExample/myNewProject.xcodeproj  
  

If I manually rename the file in ‘finder’, and then try to rename the project in xcode (works with xCode3) I get this error:

  
  
fatal: can not move directory into itself, source=apps/dptDev/emptyExample/myNewProject.xcodeproj, destination=apps/dptDev/emptyExample/myNewProject.xcodeproj/myNewProject.xcodeproj  
  

Any idea … ?

Thanks,

Hugues.

ok, I got an answer from @jvcleave on twitter

… looks like a git error. for example put the project folder on your desktop, open and rename (worked here)

it works now. I still need to better integrate my projects folder in the OF structure. I guess some changes in the .gitignore file.

Dug into this a little bit more. I removed all the .git files and .gitignore files from my OF directory and I don’t have this issue anymore.

Of course I don’t recommend others doing this if they like their openframeworks directory up-to-date with github. I am using some kinda weird pre-007 version that I didn’t mind disconnecting.

I have the same issue, any new way to solve this while keeping git synchro ?

Dragging the project to the desktop, opening in xcode, renaming, saving, putting back where it came from seems to work without issue. Its a bit of a pain, but it works

i’m looking at this problem right now with someone else… why should this even be an issue? this seems like a really weird workaround for a deeper bug.

Hey Kyle, This was happening in the early days of Xcode4. My theory was that it was an issue with its git integration/snapshot feature. Are you seeing this with newer versions?

i’m still running xcode 3, but i was helping someone else and saw this on their machine.

i remember hearing something once about projects that have spaces in their names, but we checked that and it’s not the issue.

I am still on 3.2.6 as well - do you know if they were using < 4.2?

i’m not sure. if i run into this again i’ll get the exact system specifications.