XCode Signing error after update

#1

Hi I just updated my XCODE to Version 11.0 (11A420a) and my builds started failing.

This is what i get -

Users/A/Documents/OF/of_v0.10.1_osx_release/apps/myApps/mySketch/bin/mySketchDebug.app: code object is not signed at all

In subcomponent: /Users/A/Documents/OF/of_v0.10.1_osx_release/apps/myApps/mySketch/bin/mySketchDebug.app/Contents/Frameworks/libfmodex.dylib

Command /usr/bin/codesign failed with exit code 1

#2

Just downloaded the nightly build from here, solved my problem.

2 Likes
#3

Edit your Build Settings and add --deep to the Other CodeSign Flags.

https://stackoverflow.com/questions/58195914/xcode-11-command-codesign-failed-with-a-nonzero-exit-code

It worked for me without using the nightly build.

2 Likes
#4

Yes the Nightly build worked :slight_smile:

1 Like
#5

Hi, Thanks for thr reply :slight_smile: . I followed the steps, but it did not work for me some how. I didnt understand what cleaning the product meant. But the nightly build worked for me for now

#6

I’ve kept a copy of XCode 10 because some addons like ofxSyphon have non-signed frameworks.

#7

Adding --deep to “Other CodeSign Flags” in “Build Settings” fixed the issue for me too.

1 Like