Xcode Setup Guide- can not run examples

Hi there, I really need help getting started using Open Frameworks.

I have the latest Xcode 5.0.2 and trying to run examples as shown in beginner tutorial

The Xcode 5.0.2 does not have option to run base SDK as OS X 10.6 as suggested. I tried setting them at 10.8 but there were more errors than running at 10.9 , it’s still not running - it says

#include <tr1/memory>- tr memory not found.
sorry, I could not upload the image as a new user on this forum.

Please let me know how to proceed with this as a new user.


In this thread some people have faced the same problem maybe it can help you:

Also consider using this Xcode plugin for easily adding addons to OF projects because with OF 8.0 and Xcode 5 it helps a lot if your not familiar with Xcode.

Thanks, pelayo- I have looked at the link, unfortunately it is unresolved and I suppose people have not been able to work this out. - will try the plug in as suggested and report back

Okay, so I installed the plug in but under the "OF " at the top menu, the “Add On” is greyed out. So I have no idea if it was installed.

Anyhow, I found this Trouble with noncore addons Xcode 5, of 0.8.0
where hcgije had similar problems, and I tried the setting jeonghopark suggested, now I get completely different 21 errors. It all says “Apple Mach-O Linker (ID) Error” “referened from:” etc… I have no idea what this means.
I guess not much I can do as a beginner.

Got it -


  1. fixed the setting to what jeonghopark suggested on the thread

after getting all the error of “referenced from”

2. changed the architectures to "Universal 32/64intel)

this made the examples of graphics run as said in the beginner’s tute linked in the first post. It’s very cool and exciting. I worry this is too much of a learning curve for me but will press on.


just ask alot of questions – this forum is really friendly and happy to help! good luck!