Xcode problems - weird warnings, long build times (OF 0.11.2)

Hi, I’m coming back to OF after some time away and though I used to build on the command line that doesn’t seem to be possible anymore, so I’m using xcode. Two problems:

  1. I get persistent warnings and I can’t figure out what’s causing them:
  • 6 implicit conversion warnings from ofMatrix4x4 (no idea what that is)
  • 3 warnings that TARGET_OS_IPHONE_SIMULATOR is evaluating to 0
  • A Building targets in manual order is deprecated - check "Parallelize build for command-line builds" in the project editor, Building targets in manual order is deprecated - check "Parallelize build for command-line builds" in the project editor, or set DISABLE_MANUAL_TARGET_ORDER_BUILD_WARNING in any of the targets in the current build to suppress this warning - where do I disable the manual target order building?
  • 2 warnings that Skipping duplicate build file in Compile Sources build phase: (in target 'openFrameworks' from project 'openFrameworksLib') warning - what is this?
  • A Traditional headermap style is no longer supported; please migrate to using separate headermaps and set 'ALWAYS_SEARCH_USER_PATHS' to NO. (in target 'openFrameworks' from project 'openFrameworksLib') warning - I set ALWAYS_SEARCH_USER_PATHS to NO in the project config, why am I still getting this?
  1. xcode is taking ages to build

Every time I build (which in development is often) the build time is about 60 seconds. Is there a way to set it to incremental or something? I can only imagine it’s building from scratch each time.

Thanks for any tips! <3

Hi @no_u could you try the nightly build for macOS at the bottom of the download page?
@dimitre and others have done a lot of work to reduce warnings.
https://openframeworks.cc/download/

.

For 0.11.2
One thing that can help 0.11.2 build faster is to change Build Active Architectures Only to YES for both Debug and Release in Xcode build settings. ( and as long as My Mac is the build target it should just build for your native architecture ). This should be the default in the nightly builds but isn’t set for 0.11.2

Hope that helps!
Theo