Xcode errors with Poco in 007

Hello all,

I am having a problem with running certain oF operations in 007 on Snow Leopard.

After adding ofImage.loadImage(“string filename”);
I am getting this error after compiling:

  
"std::basic_ostream<char, std::char_traits<char> >& std::__ostream_insert<char, std::char_traits<char> >(std::basic_ostream<char, std::char_traits<char> >&, char const*, int)", referenced from:  
  
Poco::Net::HTTPClientSession::proxyAuthenticateImpl(Poco::Net::HTTPRequest&)in PocoNet.a(HTTPClientSession.o)  
  

And then a bunch of other Poco lines.

I searched and checked: but it should be working in Snow Leopard? I did a complete update of my osx and xcode: Now running Mac OSX 10.6.8 and Xcode 3.2.6 with complier version GCC 4.0

How should I compile my project?

Thanks,

  • Vinesh

Are you trying to compile the latest version downloaded from github or the packaged downloaded from the OF site? I’ve never had any problem on SL using any version (git or OF site), but on Lion only the site version worked for me. Try a different one, maybe it was a night update from someone using Lion and that broke your build. Just a guess. Good luck

I downloaded it a little back - Not sure whether I downloaded it from the OF site or GitHub. I’ll download the latest GitHub version and try that again. I will post it here if it helped.

Thanks for your help!

Didn’t help unfortunately. But is no problem, I can keep using 0062 until I upgrade to osx Lion.

Well, I, like some other members of the community, have downgraded from Lion back to Snow Leopard. The problem is not the Lion, it’s a good upgrade in the OS X, but the only XCode you can use with Lion is 4, and XCode 4 sucks for anything but iOS development in my opinion. I’ve read in some other place that if you already have XCode 3 installed when you upgrade to Lion, than you can still use it, but if you’re doing a clean install, XCode 4 is the only option.

I’m using of 007 with SL and everything is fine so far. Sorry I couldn’t help you. Maybe one of the advanced users, or the dev team can help you. Good luck

I also came across the same problem. OSX 10.6.8, XCode 3.1.3, OF 007
This is a project I successfully compiled in OSX 10.7.1

  
  
Undefined symbols:  
  "std::basic_ostream<char, std::char_traits<char> >& std::__ostream_insert<char, std::char_traits<char> >(std::basic_ostream<char, std::char_traits<char> >&, char const*, int)", referenced from:  
      Poco::Net::HTTPClientSession::proxyAuthenticateImpl(Poco::Net::HTTPRequest&)in PocoNet.a(HTTPClientSession.o)  
      Poco::Net::HTTPClientSession::proxyAuthenticateImpl(Poco::Net::HTTPRequest&)in PocoNet.a(HTTPClientSession.o)  
      Poco::Net::HTTPRequest::write(std::basic_ostream<char, std::char_traits<char> >&) constin PocoNet.a(HTTPRequest.o)  
      Poco::Net::HTTPRequest::write(std::basic_ostream<char, std::char_traits<char> >&) constin PocoNet.a(HTTPRequest.o)  
      Poco::Net::HTTPRequest::write(std::basic_ostream<char, std::char_traits<char> >&) constin PocoNet.a(HTTPRequest.o)  
      Poco::Net::MessageHeader::write(std::basic_ostream<char, std::char_traits<char> >&) constin PocoNet.a(MessageHeader.o)  
      Poco::Net::MessageHeader::write(std::basic_ostream<char, std::char_traits<char> >&) constin PocoNet.a(MessageHeader.o)  
      Poco::Net::HTTPResponse::write(std::basic_ostream<char, std::char_traits<char> >&) constin PocoNet.a(HTTPResponse.o)  
      Poco::Net::HTTPResponse::write(std::basic_ostream<char, std::char_traits<char> >&) constin PocoNet.a(HTTPResponse.o)  
ld: symbol(s) not found  

I was going to install a more recent XCode, but looks like I might need to downgrade to 0.062 instead.

Hi,

yes, i just have the same problem, trying to make an OF 007 app for a 10.5 tarjet. I am on 10.6.4 and xcode 3.2.
How could we deal with this?
I can not downgrade to 0062, too many 007 specifics in my project.
here is a link to the post i was asking for a solution:

http://forum.openframeworks.cc/t/[solved-]-compiling-of-007-on-10.6-macosx-for-a-10.5-app-version-:-how-to-/9755/0

hope we solve that. it is important!

SOLVED !!!

http://forum.openframeworks.cc/t/[solved-]-compiling-of-007-on-10.6-macosx-for-a-10.5-app-version-:-how-to-/9755/3