Xcode 4.5 not supporting 10.6 SDK

@yakito
Here’s how I got mine to work: update the openframeworks.xcodeproj’s Base SDK

Thanks SOO much, I have it working now. I though with the version linked in this thread it was going to work using SDK base 10.7, but anyway I installed 10.6 and now it builds.

Thanks for the fast reply!

hey, so i’m about to update an app, even though its iOS 5, do I need to upgrade xcode & probably my OS so that its built with arm7s too?

Unless you need to update to xcode 4.5 and iOS6, I would hold off for now. It’s a bit of work to get OF to work after the upgrade and currently unreliable. I would hold off until all issues are resolved and pushed.

Speaking of which: if I can’t get my ad hoc provisioning profile to work for ad hoc distribution via Test Flight (xcode 4.5), will that get in the way of submitting to Apple?? If so, then a definite NO to upgrading @ Chris.

Hey, i ve installed the latest x code version and added the 10.06 SDK, I set it for both the project I test and the openframeworks lib like shown everywhere. When I try to run the programm I still have errors with QuickTime related stuff, what am I doing wrong? Thx guys.

Have you tried cleaning the project? Triple-check that the openFrameworksLib.xcodeproj’s Project and Target both use OSX 10.6. My project’s target is only set to OSX 10.6, the “project” is set to “Current OSX” and it works fine.

Also, I was able to successfully use TestFlight with adhoc distribution with the new Xcode, just follow the instructions in this iOS thread http://forum.openframeworks.cc/t/xcode-4.5-amp;-ios-6/10771/0

sry, i m new to xcode, how to clean the project?

Xcode Clean - Menu bar: Product > Clean, or Apple+Shift+K

Here’s what mine looks like as an example:

I made sure that both Base SDK’s were set to OSX 10.6 for the openFrameworks.xcodeproj’s “Project” and “Target” build settings. That should do it!

thank you very much, now it works fine, cleaning was the key :slight_smile:

Hi guys. I’m having problems trying to compile OF_v0072 in Xcode 4.5.1, mac osx lion 10.7.5 and mac osx 10.6sdk. When i do every step you said about changing the base sdk of the project i have the following error

If i don’t try to change the base sdk from 10.8 to 10.6, i have a “TargetConditionals.h file not found”

I have tryed everything you recommend in this post and at this link to https://github.com/openframeworks/openFrameworks/issues/1658

Thanks in advance for any help.

So finally made it. Apparently the mistake was on my Xcode library configuration or something. Did a total uninstall (deleting the xcode.app and removing all the previous libraries from older xcode versions using “sudo /Developer/Library/uninstall-devtools --mode=all”). That work for me.

Great stuff so far guys,

I’m working on getting the ofxQTSaver example running on my:

Mac OSX Lion 10.7
XCode 4.5
of_v0073_osx_release

First, I was missing the Base SDK (OS X 10.6) and found the solution on the oF forum here.

After getting that to work, I couldn’t open the openFrameworksLib.xcodeproj file. It needed to be updated, so I did that.

Now, the ofxQTSaver.cpp file is claiming “undeclared identifiers” (see attached image).

I tried to do the clean and reset the Base SDKs, taking me back to 29 Errors. -_-

I’m hitting a wall.

JP

Thanks,

JP

![](http://forum.openframeworks.cc/uploads/default/2684/Screen Shot 2012-12-07 at 12.57.37 PM.png)

Hi JP,

make sure to set the base SDK on the project as well as the target, on both openFrameworks project and the ProjectExample

Thanks, that worked for me. I had problems running the VideoGrabberExample on Xcode 4.6.2 (Mac OS X 10.6 Lion) as well.

hi,

what’s most used/stable Xcode version to work with Mountain Lion (10.8.4) and oF 0.7/0.8?

After reading all this topic I can see many people is using Xcode 4.4 and ML 10.8… (but most posts are several months old.)
Is not yet recommended to update to Xcode 4.6.3 or 4.5.2?

regards

I use 4.6.3 without a problem on ML 10.8.

Cool. Thanks! Then I go install this one too.

Are you using the 10.6 SDK too? Is not included and I need to install from an older Xcode like 4.2, Right?

Are you compiling to iOS 6?

Best

ML 10.8.4 & Xcode 4.6.3 + command tools + 10.6 SDK seems working fine here too.

1 Like

Hey I’m using OS X 10.7 with Xcode 4.5.1 + command line tools, everything is set to 10.6 SDK
Still I get this error when compiling ofxQTVideoSaver Example:

I took the SDK of another mac with Xcode3, could that be the reason?
thank you!

Okay here’s the answer to my question:


!