Xcode 4.5 not supporting 10.6 SDK

Xcode 4.5 (currently in preview state) seems not supporting Mac OS X 10.6 SDK any more.
So I’m having trouble using it since oF can not be compiled without 10.6 SDK.

Any suggestions (except downgrading to 4.3) ?

Interesting - please update us here if you find a solution! From what I understand it is mainly Quicktime that is keeping OF tethered to 32bit/10.6 SDK. There are proposals of solutions but nothing implemented at the core level yet.

Today Apple released Xcode 4.4 together with Mountain Lion and it does not support 10.6 SDK either.

I compile and run my projects after commenting out the parts that cause compile errors in these files, because my projects do not use anything in it:

  • ofQuickTimePlayer.cpp
  • ofQuickTimeGrabber.cpp

But I do really want the fixed version.

Hmm interesting. I read this just in time. Since the App store version of xCode is it hard to downgrade back to a previous version. Hoping this will be resolved soon, since for other development I need to upgrade to the 10.8 SDK.

You can download the old versions of Xcode as disk image file from Mac-Dev-Center. I have never tried to downgrade and I’m not sure if it causes no trouble, though.

Hi there,

for the time being Marek’s 64 bit OF is compiling for 10.7:
https://github.com/mazbox/of64

this could be OK for what you want to do if you don’t need video

It looks like you can add the SDK to Xcode:

/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.6.sdk

I’ve uploaded my copy of the SDK here
http://www.jamesgeorge.org/uploads/MacOSX10.6.sdk.zip

Can someone who has upgraded try this to see if it works?

I confirmed this on the github thread, but just wanted to confirm on the forum.

Downloading the 10.6 SDK and adding to Xcode works on Mountain Lion with Xcode 4.4. Everything compiles clean and video works fine.

Thanks obviousjim!

you can download xcode 4.3.3 on apple developer site and it have 10.6 sdk inside. You can have both installed 4.4 and 4.3.3

unfortunately this did not work for me. i’ve already trashed xcode and started with a fresh download… going back to 4.3.3. :frowning:

anyone else able to install 4.3.3 in Mountain Lion? I downloaded from Apple and it states I need Lion to install.

Xcode 4.3.3 works only on Lion 10.7.

Did you install Command Line Tools?
(Preferences > Downloads > Components)

Initially I skipped it but, just tried and it’s still broke. Also tried other builds… Any chance you can share a working empty example? maybe the settings i use are the problem.

could be settings.

assuming you’re working in OF 0071 you’ll have to set the Base SDK of both the openFrameworksLib.xcodeproj to 10.6 manually.

also for some weird reason the emptyExample target is missing a Base SDK selection, but you can copy and paste the entry from openFrameworksLib.xcodeproj

yeah that’s the general fix i follow anytime i setup a new project. if it helps, i have projects from 0062-71. tested across all with no luck. i guess i was hoping maybe something changed with 10.8, for example should i switch to Apple LLVM compiler or something else like that.

so far am i the only one with issues?

Ok I’m working! I’m not exactly sure which build of openFrameworks this is (as I have many for different projects) but at least one is working.

So the advice to install the command line tools must have helped! Thanks Jaeho!

I should be able to sort out the other projects from here. Probably a good reason to force me to reorganize my projects. :slight_smile:

awesome! Glad you’re sorted

every time an oF project successfully compiles a kitty gets its lulz

Another confirmation that this process works!

If you, like me, had XCode before it was in the App Store, you probably have a copy of the 10.6 SDK on your system at /Developer/SDKs/MacOSX10.6.sdk. Just copy that whole folder to /Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs like James pointed out and you’ll be home free.

You can also add a path directly to that folder by selecting “Other” as your base SDK and writing the whole path in… But then you would have to edit all your old projects.

Just to throw in my solution – I found an old version of XCode 4.2 on one of my backup disks and dragged a copy of:

/Developer/SDKs/MacOSX10.6.sdk

to:

/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.6.sdk

It now sits along side the MacOSX10.7.sdk and MacOSX10.8.sdk, which were already there (they came with XCode 4.4).

I’m running XCode Version 4.4 (4F250) and OS X 10.8.

After restarting XCode, just remember to go into build settings for both the openFrameworks sub project and your own project and set the Architectures / Base SDK to OS X 10.6 if it defaulted to “Current OS X”.