Xcode 4.5 & iOS 6

If somebody is having problems with XCode 4.5 and iOS6, just remove the armv7s architecture from your Project settings for now, in order to compile your project.


Doesn’t work for me, i still have this error :

ofiPhoneVideoPlayer.mm:44:20: No matching function for call to 'CVOpenGLESTextureCacheCreate'  

I updated XCode to 4.5 with iOS 6 SDK and i thought it would keep iOS 5.1 SDK but it just deleted it ! Does someone have a link to download it ?

Just do this:
Go to Target -> Build Settings -> Architectures
Choose “Other…”
Add “armv7”
Clean & Build

as outlined here: http://stackoverflow.com/questions/12398201/moving-to-ios6-i-get-this-linker-error-with-almost-all-external-packages

I tried to do the change, but I still have the issue with ofiPhoneVideoPlayer.mm . Am I doing something wrong?

![](http://forum.openframeworks.cc/uploads/default/2567/Screen Shot 2012-09-21 at 13.07.23.png)

Yes me too i still have this error…

Since my project isn’t using video playback, I just commented out those lines…I feel so dirty now.

It look like those lines are in an ifdef just for iPhone 5.

the ofiPhoneVideoPlayer issue is being fixed but for anyone that is desperate and needs it to be fixed right away, it can be done in the following way.

inside ofiPhoneVideoPlayer.mm

CVReturn err = CVOpenGLESTextureCacheCreate(kCFAllocatorDefault,  
                                            (__bridge void *)ofxiPhoneGetGLView().context,  

the new LLVM 4.1 compiler doesn’t like the

(__bridge void *)  

you can remove it so the new code will look like,

CVReturn err = CVOpenGLESTextureCacheCreate(kCFAllocatorDefault,  

this will fix the ofiPhoneVideoPlayer issue.

these issues will be fixed in the next OF release (0072).
for now, please use the fixes in this post until the next release is out.

Were you able to build onto a device?

I was able to get the Simulators to compile by doing this: http://forum.openframeworks.cc/t/xcode-4.5-not-supporting-10.6-sdk/10343/34
use iOS 5.1 as the Base SDK

The downside, however, is that I’m getting an error when building to a device.

(null): Linker command failed with exit code 1 (use -v to see invocation)

ld: file is universal (4 slices) but does not contain a(n) armv7s slice: /Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS5.1.sdk/usr/lib/crt1.3.1.o for architecture armv7s
clang: error: linker command failed with exit code 1 (use -v to see invocation)

When I attempt removing the architectures as you mentioned, I get this error when the app launches on the device:

Could not launch “Game”
failed to get the task for process 1726
error: failed to launch ‘/private/var/mobile/Applications/A/Game.app’ – failed to get the task for process 1786

Any thoughts?

the error suggests it could be something to do with the Entitlements.plist which is used when distributing an adhoc build.

depends how you have your project setup…
but have you tried building a debug version to your device, not release build?
and just make sure you’ve added Entitlements.plist to CODE_SIGN_ENTITLEMENTS only for Release build.

Switching provisioning profiles did the trick, but now I dunno how to send out the latest build to my team :stuck_out_tongue:
Would updating the provisioning profile help?

Combining the solutions that Nils and Julapy gave, it worked for me.

Thanks guys

This fixed the issue for me. Thank you.

I tried again @hokori and got it to work this time.
Setting “armv7” allows compiling onto a device and ad-hoc distribution! :slight_smile: Thanks all

Hi guys, I just updated to M.lion and ios6 but I didn’t get any error whatsoever, why is that so? anybody knows why some people got the error and some don’t? The reason I hesitated to update all this time was because I was afraid that the update might brake OF (007)

Definitely understandable, I’m the same way. Did you pull from the repo? It was a reoccurring thread seen, “touch events registering twice”, “xcode 4.5 doesn’t work”, etc. I think they cover those changes here https://github.com/openframeworks/openFrameworks/pull/1595

Hi, yeah, I did some more testing and definitely things are not 100%-ok.
events are registering twice, ergo… constructors are called twice… my wrapper of AVPlayer is not behaving properly, videos doesn’t rotate, it’s a big mess, I am going to try using the newest OF from the repo and see what happens Thanks for the link!

… OF has gone a long way since 007, -everything is different now-