Xcode 10, OF 0.10.1 - will not build for simulators


#1

I can build and run on devices, but not for simulators. I am working on High Sierra (10.13.6), Xcode 10.0, and OF 0.10.1. The error message I get is ‘linker command failed with exit code 1’.


iOS example simple build fails
#2

If anyone has been able to run OF on simulators using Xcode 10, please put your hand up.


#3

I’ve done a bit more digging and have a more specific error message:

/openFrameworksCompiled/lib/ios/libofxiOS_iphoneos_Debug.a, file was built for archive which is not the architecture being linked (x86_64):
/openFrameworksCompiled/lib/ios/libofxiOS_iphoneos_Debug.a
:-1: symbol(s) not found for architecture x86_64


#4

this sounds like a bug, can you open an issue in github?


#5

OK - I have opened the issue on github.


#6

Seems to do with the file name being incorrect? I made a copy of
libofxiOS_iphonesimulator_Debug.a and called it libofxiOS_iphoneos_Debug.a

The simulator then worked for me.


#7

stubbulon5 - where did you find that file?


#8

OK, I have found the file. But it seems the issue is not that the iphoneos file is not present (iphoneos and iphonesimulator are both present) - rather, the error message says that an architecture is missing in that file:

/Users/rherrema/Documents/Frameworks/of_v0.10.1_ios_release/libs/openFrameworksCompiled/lib/ios/libofxiOS_iphoneos_Debug.a, missing required architecture x86_64 in file /Users/rherrema/Documents/Frameworks/of_v0.10.1_ios_release/libs/openFrameworksCompiled/lib/ios/libofxiOS_iphoneos_Debug.a (2 slices)


#9

The following worked for me:
1.) Clean your build folder
2.) Target iOS 12 (probably not essential, but hey…)
3.) Important, if using the latest macOS (Mojave) / Latest Xcode 10, you need to use the LEGACY build system. NOT the new.

To use the legacy build system, select it in the File > Project/Workspace Settings sheet. Projects configured to use the legacy build system will display an orange hammer icon in the Activity View.

Also, if you’re using any non-standard ofxAddonsyou need to make sure you include the necessary framework. I’m using ofxSVG, and had to add “libxml2.tbd”![08|689x491]to get unblocked (see screenshot)

Hope it helps man…


#10

Hey thanks ! This worked for me.


#11

This helps me


#12

Changing to Legacy Build System worked for me, as well. Thanks.


#13

Thanks for this - worked.