Xcode 10 / mojave issues


#1

EDIT: This should now be all fixed in the current release. Go to https://openframeworks.cc/download/ to get it.

If you are having issues with xcode 10 and latest macos. It is a known problem and we are looking into it.

By now we recommend not updating to mojave or xcode 10.

Xcode 9 should work fine but if you’ve updated to mojave there might be some issues running applications that use the camera, sound or in general any peripheral that now needs specific permissions.

The errors we have detected include

  • You need to move the window for the app to start drawing
  • video Camera, sound input… wont’ work
  • xcode rebuilds all of OF every time
  • Applications don’t compile at all complaining that quicktime framework doesn’t exist
  • Applications don’t compile at all complaining that i386 is not a supported platform

The last 2 issues have been solved in the nightly builds which you can find in the downloads page below the normal downloads


Window not drawn on startup using Xcode10
Flickering, ofSetBackgroundAuto(false), and no double buffering?
#2

#3

#4

#5

#6

#7

to fix the “xcode rebuilds all of OF every time” w/ Xcode 10 you can use the legacy build system

File, then Project Settings or Workspace Settings. Choose legacy build system:

image


#8

When you say Camera, do you mean ofCamera or ofVideoGrabber?


#9

i mean video, that’s all related to permissions to access devices that the latest macos has introduced


Indexing files, building OF every time
#10

did u solved the camera and sound issue?


#11

UPDATE: I fixed this problem asking permission on the plist just like ios apps
just add these lines to the plist default template

<key>NSCameraUsageDescription</key>    
<string>This app needs to access the camera</string>
<key>NSMicrophoneUsageDescription</key>; 
<string>This app needs to access the microphone</string>

[upgrade Mojave] audioInput no longer working of_v10[solve!]
#12

The semicolon confused me a bit but once removing this it worked! Thanks!


#13

I posted a message about some issues I encountered with Xcode 10 and Mohave. I now see this topic. Some of the questions I had are already mentioned in this post (sorry for that), some seem new.


#14

That fixes the camera problem indeed. Thank you!


#15

Something happened with Mojave and QtCreator as well. After fresh installs of oF0.10.0, QtCreator, and the Xcode command-line tools, a new project will no longer build or run. In Projects > Build and Run > Run Settings, the Run fields are empty. I wish I had read this post before upgrading. Dang. Its all likely related but if this issue belongs in a new thread then feel free to move it.

Edit: The polygonExample will import and build and run, but it doesn’t run like it should (no graphics in the window); the same is true with the 3DPrimitivesExample.

Edit: a copy of emptyExample will build and run, and will cout something to the terminal, but won’t draw an ofDrawCircle() or ofBackground()

Edit: updating Qt to 4.7.2 did not resolve the issue


#16

We’ve been working on some fixes for the Mojave / Xcode 10 issues.

It would be helpful if people running Mojave could test: https://openframeworks.cc/versions/mojave/of_v0.10.0-mojave_osx_release.zip

The rebuilding the entire library issue and permissions should be fixed now and it includes a newer GLFW version which should address the rendering issues people were running into.

We’re tracking the issue here: https://github.com/openframeworks/openFrameworks/issues/6149
but you can post to this page if you don’t have a GitHub account.

Thanks!!
Theo


#17

Okay here is another release which should also default to the legacy build system which fixes a lot of the strange quirks with Xcode 10.

The only issue which isn’t resolved is the vertical sync issue. Apparently this is actually a bug in 10.14 and is fixed in 10.14.2 beta.

https://openframeworks.cc/versions/mojave/of_v0.10.0-patch-mojave-rc5_osx_release.zip


ofxGui Mojave + Xcode 10 bug?
Window not drawn on startup using Xcode10
No rendering initially in Mojave
#18