Working with old apps on Linux


#1

Hello!

I’ve recently tried coming back to OF and I’m having an absolute nightmare trying to figure out what’s happened since I last worked with the project.

I built some apps a long time ago in the 0.06/0.07/0.08 era, most of which heavily relied on being able to use ofxVideoRecorder. I gather one of the core dependencies of this addon is no longer supported in the latest OF (Poco), so I’ve been trying to find some combination of older versions which will let me get back on my feet.

Sadly, 0.8 etc won’t let me install dependencies on modern Ubuntu. I can’t run Ubuntu 13 on modern hardware. All the middle ground seems to be a shitshow due to mismatches in dependencies and requirements.

I was hoping that the last of the 0.9 series (0.9.8) might give me some joy, but it’s falling over trying to build OF with more Poco errors.

Please could anyone familiar with the last few major releases let me know which version still supports / includes Poco (and could therefore hopefully support ofxVideoRecorder), and which version of qtcreator goes with it? Every thread I find refers to the ‘latest build’ or the ‘nightly build’ rather than a version, so I’m going round in circles trying failing combinations :frowning:

I can quickly install either Ubuntu 16 or 18 to suit a working combination, I just don’t know what to look for - if the OS version makes a difference?

Any help much appreciated, I’ve missed this a lot! :slight_smile:

Kee


#2

Quick update that I think I’ve got a semi-workable setup using Ubuntu 16 and OF 0.8 by fudging the /etc/apt/sources list to include “http://old-releases… saucy etc” as well as the ‘standard’ repos.

Codeblocks keeps falling over and losing track of what’s in the project, but that’s another battle :smiley:


#3

poco is still supported, you just need to include ofxPoco in your project


#4

thanks dude - I think I tried that and still had a failure about poco/condition.h, but I’m about to try rebuilding from scratch in latest everything (ubuntu 18, OF 0.10, QT 4.6.1) as it seems pretty silly trying to keep on a path using old releases.


#5

@arturo I had a look through the ofxPoco addon and it seems to be exclusively for handling XML aspects of the library - is that correct?

If I try to install the libpoco-dev package on Ubuntu 18 I’m hitting all sorts of errors which indicate the current version of that library is no longer compatible with the code from ofxVideoRecorder.

Out of interest, are you aware of any other libraries/addons I could use to achieve the same effect as ofxVideoRecorder? I need to programmatically control the recording of getPixelData() (now presumably getPixel().getData()) output and store to a video file via ffmpeg (though I’ll take any option really!).


#6

Another update - I’ve made progress by essentially just using the build config from the ofxPoco addon and deleting all of the ofxXmlPoco code which was causing problems - everything thread-related which ofxVideoRecorder required is now working \o/


#7

ofxPoco contains all the poco libraries. It appears to be only xml related cause we moved the old ofXml from the core into that addon as well since it was based on poco but it also contains all the libraries in libs/poco which will be automatically added to your project by qtcreator when you add the addon to a project