Windows: make Error 127


#1

Hello,
I have a problem when I try to run any example with OF 0.10 nightly (any versions even those that use to work). Windows 10, followed a few times the install procedure, even deleting msys64 and reinstall it back.

$ make RunRelease
HOST_OS=MINGW32_NT-10.0
checking pkg-config libraries:   cairo zlib openssl glew glfw3 libcurl
with PKG_CONFIG_LIBDIR=
make: *** [/d/of_v20180411_msys2_release/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:199: RunRelease] Error 127

This error can mean that the path is not found, I moved c:\msys64\mingw32\bin and c:\msys64\usr\bin and to the very beginning of my PATH variables.

When I try to manually launch the EXE file I get something like this:
Entry point for “FT_Done_MM_Var” not found in library C:\msys64\mingw32\bin\libcairo-2.dll

Did you run through the same thing ?


#2

Hello again,
Sorry to bump on this but I didn’t find an issue with this.
I updated msys2 and compiled and try to run with same version. Tried with latest OF 180415.

The executable doesn’t find what it is looking for in “libcairo-2.dll”.

I copied the dll in the folder of an example but it gives the same error with the new path.

The error is this:
Entry point for “FT_Done_MM_Var” not found in any path\libcairo-2.dll

I’m clueless :face_with_raised_eyebrow:


#3

I got examples working by copying all the necessary dlls into the bin folder with the command:
$ make copy_dlls

For example, this is 23 Mo of added data for 3DPrimitivesExample. So not perfectly satisfying but it works !

If the very same dlls are located in another directory and added to system path, it runs into the same error: cannot find entry point in …dll
very weird :hushed:


#4

Ok.
Sorry for the spam but I was kind of obsessed with it.
So I tried each one of the dlls and it seems like the only one that is needed into the local bin folder is :
libfreetype-6.dll
EDIT: apparently part of ‘cairo’ librairy

This file is also located on my computer at:
C:\Windows\SysWOW64
I tried renaming it quickly to confirm it was the problem: confirmed.

but this path isn’t even in my Environment Variable Path list !!
EDIT:
https://msdn.microsoft.com/en-us/library/windows/desktop/ms682586(v=vs.85).aspx#search_order_for_desktop_applications
You can read here the order for DLLs to be looked at by windows. My cairo lib is not up to date on my machine but I won’t mess with it and will keep copying the needed DLL into the local bin directory for now. it works.