Windows 8.1 can't open .mp4 file

Trying open a .mp4 file that Windows Media Player is able to play fine and I get this message in the console:

" Cannot load video of this file type.  Make sure you have codecs installed on your system.  OF recommends the free K-Lite Codec pack. 

I have installed the K-Lite Mega Codec pack 12.5 - any other clues?

Hey Jason!

Did you check to make sure the path was valid?
It should work with the codec pack.

The one we recommend is: https://ninite.com/klitecodecs/

Cheers!
Theo

Just tried the ninite but same deal.

Is there an environment variable I need to set? I am not seeing anything that looks related

Thanks!

hmm - even the videoPlayerExample is giving the same error

I am having the same issue on Windows 10 with OF 0.9.0 and 0.9.3
Its really strange - it looks like an issue with getConnectedMediaType which I think means that the codecs aren’t working.

Do any other video files work for you?

Might be good to move this over to github too.

Theo

I only tried my video and fingers.mov

Looks like there is a bug report already

https://github.com/openframeworks/openFrameworks/issues/5114