Window not drawn on startup using Xcode10


#1

Hi, I updated Xcode to version 10 after updating my macOS to the latest 10.14.

However, when I run a simple OF project that draws a red circle in the center, nothing is drawn on the window and even the background color looks white and not default grey.

It works again once I move position of the window using mouse.

Also, the following message appears on the console:

2018-10-24 00:01:55.949915+0900 emptyExampleDebug[11494:1805156] [default] Unable to load Info.plist exceptions (eGPUOverrides)

I think this message didn’t appear when I ran the project using Xcode9.
I tested this on both stable release and nightly build and they all have this problem.

Is this a known issue?
If not, I would appreciate if any Xcode10 user can confirm this issue.


#2


I think you didn’t search much :slight_smile:

Would be nice to merge the question into one thread maybe? I don’t have permission to do that…


#3

See also


#4

This should be fixed now in master. Here is a rc test which should work for Xcode 10 / 10.14