win7(64) vs2010 clone emptyExample - font not allocated

I’ve previously and successfully used oF v .0060 with vs2008 about a year ago.

I’ve loaded the .0062 vs2010 version and ran into dificulties with a simple hello world I created from a copy of the emptyExample. I have successfully compiled and run the .0062 fontsExample. (after the emptyExample trouble I also tried cloning the fontsExample with the following same load font problem)

OF_ERROR: Error : font not allocated – line 779 in c:\users\jeffa\development\of_prerelease_v0062_vs2010_fat\of_prerelease_v0062_vs2010_fat\libs\openframeworks\graphics\oftruetypefont.cpp

win 7 64 bit
visual studio 2010
of_preRelease_v0062_vs2010_FAT

I copy the emptyExample to a new directory at the same level in the directory tree.
I rename the directory to jHelloWorld
In the jHelloWorld directory I rename the emptyExample.* files to jHelloWorld.*
in the .sln file I make these changes:

  
  
Project("{8BC9CEB8-8B4A-11D0-8D11-00A0C91BC942}") = "jHelloWorld", "jHelloWorld.vcxproj", "{7FD42DF7-442E-479A-BA76-D0022F99702A}"  
EndProject  
  

and in the .vcxproj file

  
  
    <RootNamespace>jHelloWorld</RootNamespace>  
  

Are there any other places I need to change?

Based on this article I believe that somehow the relative path may be mangled. http://forum.openframeworks.cc/t/data-path-issues-from-comand-line-0.061/3713/0
(FYI I’m running from the IDE not the command line)

thanks, - jeffa

Solved. Mostly…

in the property pages for the project under Configuration Properties the Working Directory should be: “$(ProjectDir)/bin” once I made this change I successfully ran the program from the ide.

I checked the examples included with the distribution. They were set corectly as above. However when I make copies of a project and refactor as in my original post the Working Directory is: “$(ProjectDir)” without the /bin. ??? I wonder where the ‘bin’ get’s lost?

c ya… - jeffa

how do i use the loadfont() function. should i be directly be pasting the .ttf file in the data folder i m working in linux and in terminal

  
OF: OF_LOG_ERROR: ofTrueTypeFont::drawString - Error : font not allocated -- line 726 in ../../../openFrameworks/graphics/ofTrueTypeFont.cpp  

please help i m stuck