when install QuickTime7.7.1 OF open file failed

Hi guys,

I have installed quicktime7.6.9 before, and use OF to open movie file. In my source it can worked well.
when i installed QT7.7.1 instead of QT7.6.9,the sample also worked. but when movie file full path does’t all include Letter and Digital(like D:\Media??), OF open file failed(error -36). if i use QT7.6.9,it works well.
when OpenMovieFile method is called, it will get error -36.
my OS is windows xp.

Can someone help me. Thanks in advance.

i’m pretty sure you need to use wide strings instead of normal strings to store something like “??”. right now openFrameworks only uses normal strings throughout the entire core, so any wide unicode characters will not work. sorry!

thanks for you reply.
but i did’t change openframeworks version. i only use QT7.7.1 instead of 7.6.9.
cause OpenMovieFile method is provided by QT SDK, i think wide unicode characters was supported in QT7.6.9 and it’s SDK. After the QT upgrate, is it not support wide unicode characters?
Since version7.6.9 support, i think version7.7.1 will also support wide unicode characters.

The problem isn’t in the quicktime code, it’s in how OF interprets your ?? and passes it to QT unfortunately. You might be able to store those characters as the unicode char values and convert them to wide strings and pass them to QuickTime using something like wcstombs() (more info here: http://www.cplusplus.com/reference/clibrary/cstdlib/wcstombs) but I’m actually not sure :confused:

also, try saving the cpp as latin-1 encoding instead of utf-8