Warningssss

I’m trying to build oscSenderExample with Codeblocks 10.05 mingw and OF v0062 FAT but get this warnings:
So if any of you can give me some info on what i have missed. I followed this instructions:

http://www.openframeworks.cc/setup/codeblocks

-------------- Build: release in oscSenderExample ---------------

Compiling: …\addons\ofxOsc\src\ofxOscMessage.cpp
Compiling: …\addons\ofxOsc\src\ofxOscReceiver.cpp
Compiling: …\addons\ofxOsc\src\ofxOscSender.cpp
Compiling: src\main.cpp
Compiling: src\testApp.cpp
Compiling: …\addons\ofxOsc\src\ofxOscBundle.cpp
Linking console executable: bin\oscSenderExample.exe
Warning: .drectve -defaultlib:LIBCMT ' unrecognized Warning: .drectve-defaultlib:OLDNAMES ’ unrecognized
Warning: .drectve -defaultlib:LIBCMT ' unrecognized Warning: .drectve-defaultlib:OLDNAMES ’ unrecognized
Warning: .drectve -defaultlib:LIBCMT ' unrecognized Warning: .drectve-defaultlib:OLDNAMES ’ unrecognized
Warning: .drectve -defaultlib:LIBCMT ' unrecognized Warning: .drectve-defaultlib:OLDNAMES ’ unrecognized
Warning: .drectve -defaultlib:LIBCMT ' unrecognized Warning: .drectve-defaultlib:OLDNAMES ’ unrecognized
Warning: .drectve -defaultlib:uuid.lib ' unrecognized Warning: .drectve-defaultlib:uuid.lib ’ unrecognized
Warning: .drectve -defaultlib:LIBCMT ' unrecognized Warning: .drectve-defaultlib:OLDNAMES ’ unrecognized
Warning: .drectve -defaultlib:LIBCMT ' unrecognized Warning: .drectve-defaultlib:OLDNAMES ’ unrecognized
Warning: .drectve `/DEFAULTLIB:“LIBC” /DEFAULTLIB:“OLDNAMES” ’ unrecognized
Running project post-build steps
xcopy /e /i /y “D:\2012\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\oscSenderExample…\export\win_cb\*.dll” “D:\2012\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\oscSenderExample\bin”
D:\2012\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\oscSenderExample…\export\win_cb\fmodex.dll
D:\2012\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\oscSenderExample…\export\win_cb\FreeImage.dll
D:\2012\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\oscSenderExample…\export\win_cb\FreeType-6.dll
D:\2012\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\oscSenderExample…\export\win_cb\glut.dll
D:\2012\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\oscSenderExample…\export\win_cb\qtmlClient.dll
D:\2012\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\oscSenderExample…\export\win_cb\zlib1.dll
6 File(s) copied
cmd /c if not exist “D:\2012\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\oscSenderExample\bin/data” mkdir “D:\2012\of_preRelease_v0062_win_cb_FAT\apps\addonsExamples\oscSenderExample\bin/data”
Process terminated with status 0 (0 minutes, 13 seconds)
0 errors, 17 warnings

warnings are ok, your program has compiled without errors so it should run. have pressed the run button? or only the build one

It works but I’d like to know the reason…

Thanks!

Same results on Windows XP and Win 7 with all apps examples and addons examples !!!
???

yes this warnings have been there always as far as i remember, i don’t know the reason but they don’t really matter