[warning] ofGstVideoUtils: update(): ofGstVideoUtils not loaded - RPI3


#1

Yes this old problem … :frowning:

Running 0.10 on RPI3 B+ under latest Raspbian lite. OF, dependencies and codecs installed as per documentation… Raspberry Pi camera works ok from the command line: raspistill -o cam.jpg

videoPlayerExample runs and shows movie , but videoGrabberExample does not. No video and the above error repeating in the log output to terminal.

How can I get this working??
(output from dpkg -l | grep gstreamer. shown below:)

Thanks.

ii gir1.2-gstreamer-1.0 1.10.4-1 armhf GObject introspection data for the GStreamer library
ii gstreamer1.0-alsa:armhf 1.10.4-1 armhf GStreamer plugin for ALSA
ii gstreamer1.0-libav:armhf 1.10.4-1 armhf libav plugin for GStreamer
ii gstreamer1.0-omx 1.10.4-1+rpt3 armhf GStreamer OpenMAX plugins
ii gstreamer1.0-omx-rpi 1.10.4-1+rpt3 armhf OpenMax plugins for GStreamer
ii gstreamer1.0-omx-rpi-config 1.10.4-1+rpt3 armhf OpenMax plugins for GStreamer
ii gstreamer1.0-plugins-bad:armhf 1.10.4-1 armhf GStreamer plugins from the “bad” set
ii gstreamer1.0-plugins-base:armhf 1.10.4-1 armhf GStreamer plugins from the “base” set
ii gstreamer1.0-plugins-good:armhf 1.10.4-1 armhf GStreamer plugins from the “good” set
ii gstreamer1.0-plugins-ugly:armhf 1.10.4-1 armhf GStreamer plugins from the “ugly” set
ii gstreamer1.0-pulseaudio:armhf 1.10.4-1 armhf GStreamer plugin for PulseAudio
ii gstreamer1.0-x:armhf 1.10.4-1 armhf GStreamer plugins for X11 and Pango
ii libgstreamer-plugins-bad1.0-0:armhf 1.10.4-1 armhf GStreamer development files for libraries from the “bad” set
ii libgstreamer-plugins-base1.0-0:armhf 1.10.4-1 armhf GStreamer libraries from the “base” set
ii libgstreamer-plugins-base1.0-dev 1.10.4-1 armhf GStreamer development files for libraries from the “base” set
ii libgstreamer1.0-0:armhf 1.10.4-1 armhf Core GStreamer libraries and elements
ii libgstreamer1.0-dev 1.10.4-1 armhf GStreamer core development files