Warning : before upgrading to Xcode 7

And about Who have updated before Know that?
In my case!

I think you’ll have to go to Apple’s Dev page and manually download Xcode 6. Or trust the internet. :smile:

Update: @admsyn as an easier solution.

1 Like

I downloaded ''MacOSX10.10.sdk ‘’ from your ''trust the internet" and put into

“Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs” folder.

Surprise!!!It’s not working

I got #include “Poco/Net/HTTPClientSession.h” error about OpenSSL

Did you set “OS X 10.10” to “Base SDK” setting for “openFrameworksLib.xcodeproj” ?
Actually the target setting does not seem to matter, but the more important thing is the setting in openFrameworksLib.xcodeproj.

1 Like

I was just changing the MYProject “Base SDK” :smile:
And not “openFrameworksLib.xcodeproj” from openFrameworks folder.

Now it’s just working.

It solved my problem
Thank you jaeho

Solved the problem ! Thank you

How do I update the Base SDK setting in openFrameworksLib.xcodeproj?

you go on project settings (the blue icon on the project tree under openFrameworks). It’s in the menu build settings

I downloaded ''MacOSX10.10.sdk ‘’ and changed the"Base SDK",but there is still an error ,‘openssl/opensslconf.h’ file not found.

@Evie: You have to change it in your project and in the openframeworks project.

Yes.I changed, but the problem cannot be solved.

Did you change the settings of the “target” instead of “project” as in the attached image?

I’ve just tried but the error is still there," ‘openssl/opensslconf.h’ file not found" .

We’ll see how long this lasts, but I’ll try to save some people some trouble:


Thank you for posting this!

There may be a better way :slight_smile:

EDIT: there’s a simpler version of this fix that doesn’t involve manually installing openssl

The issue looks like openssl has been removed. You can install openssl with homebrew

brew install openssl

…and then add its path to the openFrameworks project:

  • Click on the openFrameworks project in Xcode to show its build settings
  • Select User Header Search Paths and add this:

To fix this for all your projects, open the file CoreOF.xcconfig in libs/openFrameworksCompiled/project/osx/ and add the following line at the bottom:

USER_HEADER_SEARCH_PATHS = $(INHERITED) /usr/local/opt/openssl/include

Thank u!!!My problem was solved!

Great, thank you! Trusting the Internet and following your instructions helped me fixing the problem.

In particular, I had troubles compiling the examples/addons/kinectExample project in the 0.8.4 OF OSX release. Following your instructions, no additional changes needed, it compiles (and runs) just fine now.

Yay! Thank you!!!

Thank you so much!!!