voice recognition on PC

Hi everyone.
There’s an addon , ofSpeech, which seems to be about voice recognition, but it’s uses Carbon, which doesn’t exist on windows (as far as I know … ).

Is there an equivalent for Win7 ?

It might be a little overkill but if you have access to a Kinect you could use ofxKinectNui.

^^ I finally bought a kinect.
I am going to try ofxKinectNUI now.
Thanks for the advice ^^

Hi ,

I think I downloaded and installed everything needed. But I get this error when trying to compile :

  
..\..\..\addons\ofxKinectNui\src\kinect\nui\AudioStream.h|20|fatal error: wmcodecdsp.h: No such file or directory|  

and I couldn’t find this file anywhere on my computer.( I am on win7 ) But I had not installed visual C++ express. So I installed it. I have now the missing file “wmcodecdsp.h” and a bunch of other ones.

Then I tried to add some search directories in my codeblocks projects as the compiler was complaining about missing files. ( I seem to have them all now )
But it never stops complaining about missing files. ( I mean , as soon as I add a new search directory, the error jumps the next missing file, and so on …)

Are there some specific libraries to point to ?

Actually I was wrong , I had to add two search Directories until the error becomes :

  
C:\Program Files (x86)\Microsoft SDKs\Windows\v7.0A\Include\winnt.h|851|error: #error Must define a target architecture  

Anyone has a clue about what I can do to go around that ?

Hi again.
I haven’t been able to make it work yet. I don’t really know what I am doing, and I must say … this is a real jungle out there : I spent the last two days trying to figure out what’s happening. I installed ( and tried to install ) numerous versions of visual studio express ( I finally installed a trial of visual studio ultimate 2013) . I also installed 32 and 64bit versions of Windows SDK.

The first file missing “wmcodecdsp.h” can be found here on my PC:
C:\Program Files\Microsoft SDKs\Windows\v7.0\Include

the second file the compiler is complaining about is “sal.h” . and the only places I can find this header file is in :
C:\Program Files (x86)\Microsoft Visual Studio 12.0\VC\include
or
C:\Program Files (x86)\Microsoft Visual Studio 10.0\VC\include
or
C:\Program Files (x86)\Microsoft Visual Studio 9.0\VC\include

I can’t find a 64bit version of sal.h , and does it even exist ?
Do you think it has something to do with my problem ?

That means that you don’t have the application accessing all the main windows libraries correctly. You need to have all the windows media object headers included:

  
#include <dmo.h>