Visual Studio 2017 compiling problems


#1

Hi there !
I’m trying to compile the polygonExample with a freshly new install of Visual Studio 2017, installed as follows:

When compiling i got loads of erros like this:


Sorry for the french version but it generally says that a caracter is missing or is unexpected in a source file

Can anyone help me ?


#2

did you try creating the project with ProjectGenerator?


#3

First I tried without using it and I got errors as shown, then I updated the project with the ProjectGenerator but I have the same problem now …


#4

You’re not upgrading the projects here, right?


#5

Thanks for your answer again !
I upgraded the project before so I think I can’t rollback the upgrade …
So I Loaded another example project (blendingExaple), updated with the projectGenerator before and not upgraded with an SDK or toolset and now I have to deal with theses errors:
“C1083 : Unable to open include file: ‘winsock2.h’: No such file or directory”
"LNK1104: Unable to open file : ‘Ws2_32.lib’ "

As far I search over internet it’s seems to be an path problem of the SDK ?


#6

Which modules did you install with visual studio? The installer gives a lot of freedom but some parts are needed to compile OF. I Had to explicitly check the windows 8.1 SDK and the Windows 10 SDK 10.0.15063.0


#7

To be sure of a 100% compatibility I checked them all, but yeah it’s not 100% …
As I remember I check for sure all of the win 10 sdk and the 8.1 sdk.


#8

random question @Gui96, have you tried repairing your VS2017 install? I had a few things go wrong after I uninstalled vs2015, but a repair fixed them.


#9

Hi, I didn’t tried but I 'll try it out in few days. As a partial solution I’m debugging on a Linux OS which works really good but without a good IDE. Any recommendation ?
Thanks for yours replies !


#10

Did you try Qt Creator? It’s no match to Visual Studio but still a decent IDE to work with. And has good integration with OF

But, anyway, VS 2017 on Windows should work. May be trying a fresh install in a virtual machine could give you a hint about what’s happening in your current installation