Visual Studio 2017 compiling error

Hello Frameworkers.

I’m having trouble compiling my first code with Visual Studio 2017.

I did a project from the Project Generator and from the VS itself.

I attach the images.

I followed the vs 2017 installation guide according to the OF tutorial, install the OF plug-in.

In the project properties, indicate that I used the V141 build tools, both in my code and in openframewroksLib.

I had the VS 2019 installed that uninstalls.

Uninstall and reinstall VS 2017 and still order the V142 build tools.

In VS 2017 I installed:

(see images)

My OS its W10 64 bits.

Someone could help me very much thank you.

Best regards.






what happens when you set it to 64?

Screen Shot 2021-07-17 at 9.41.53 PM

also, maybe this is helpful

For this error, and similar, for other platforms (e.g. VS2013) this problem typically occurs because you installed an older version of VS after you installed a later one.

Thank Zach for you answer.

When I set it to 64 the ouput compiling its:

1>------ Operación Compilar iniciada: proyecto: openframeworksLib, configuración: Debug x64 ------

1>openframeworksLib.vcxproj → Y:\OF VS 2017\of_v0.11.2_vs2017_release\libs\openFrameworksCompiled\project\vs…\lib\vs\x64\openframeworksLib_debug.lib

========== Compilar: 1 correctos, 0 incorrectos, 1 actualizados, 0 omitidos ==========

Well Great 1 correct and not error but nothing happen, I supposed that a graphical window should open showing me what the code does but this does not happen.

maybe try the “start without debugging” from the menu

YEA YES It WORK YAHOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOOO

THANKS very very much.
Well them if I want my code, I get any example delete yours addons and your code, add the new addons if necesaire and re wirte code for my pourpose. Now its too later in Argentina, morning try.
Best regards.

I tyr directly generate a new project by Files → New openframeworks and it work perfectly. Problem SOLVED.
Thank I’m happy