Visual Studio 2017 Beginner , compiles fine but nothing happens

Greetings.

When I compile any example ie. soundPlayerExample nothing happens and nothing is rendered on screen.
I’m probably missing something pretty basic here but hoping you guys have patience to explain.

I do get:
========== Rebuild All: 2 succeeded, 0 failed, 0 skipped ==========
when I run as DEBUG-Win32 platform configuration.

so I believe everything is fine but I dont get anything rendered on screen. Basically nothing happens.
I look at this and its similar to what I do (…loud audio in video) :


and yet I dont see the window that pops up with Synth.Beats.Vocals.

Is it related to opengl and any pointers how I can solve this?

I installed Openframeworks 0.10 with Visual Studio according to instructions on download page.

I also added additional components that might be required such as Windows 10 SDK 10.0.15063.0 and Windows 8.1 SDK along with other C++ related packages.

of is at: C:\Users\nervusvagus\source\of_v0.10.0_vs2017_release

Laptop build: asus n550j / Win 10 / NVIDIA GTX750M

Hey, can you run other examples?

nope I cant run any. there seems to be some response when I run with Debug>Graphics>Start Graphics Debugging , I see a screen popup but its either blank or with unrecognizable texture depending on the example I run.

can you try updating the graphics card drivers? Also laptops usually have an interl and an nvidia card and applications by default run on the intel. you could also try to setup the specific OF example to run on the nvidia and see if that helps

I see what you mean, tried it earlier with setting OpenGL to use Nvidia as per the image I attach, but nothing changed.

In “Select the program to customize” you have to select the example, not visual studio. But also i would try updating the drivers if that fails, even the intel ones

I tried applying “OpenGL to use Nvidia” in the above screenshot again and I guess with this when I do Debug>Graphics>Start Graphics Debugging in VS the soundplayerExample finally loaded. It works with this, but does not work from the Build> menu in any way.

all drivers are updated to latest but will try reinstalling the intel drivers rather than the windows 10 - asus provided ones