Videos not playing in exe build in release mode

I just tried a test deployment on one of my machines. The application runs fine when I use the ApplicationName_DEBUG exe generated from the build. However, when I try to run the same application by running the exe which was generated in Release mode, the videos that I have in my application stop running. The branch of code that draws the videos instead draws only a white rectangle and no video frames.

The Debug exe is approx. ~47 MB whereas the Release mode exe is ~5MB only.

I had a problem earlier with Debug exe as well as far as I remember, after which I installed QuickTime and a Codec pack and I got the videos running fine).
I’m on Windows 7 machine (with Intel HD4000 graphics). Any suggestions on why the videos might not be appearing correctly as they do in debug exe?


In another test deployment just now, noticed that the sound on the videos plays fine in Release mode, but the video frames/textures still do not appear (instead a white rectangle is there). Images and other textures appear fine. Is there some common mistake that can be pointed out in such a case when the videos play fine in Debug mode and not in Release mode.

On my dev machine, if I build in Release mode in Codeblocks and launch the application after compiling, I still get proper results and the videos appear fine. The white rectangle issue on videos happens only the on test deployment machine.

EDIT: Sometimes, the videos don’t play on debug exe as well. However, when I restart the machine, the videos appear back and play properly afterwards.

I’m having the same, or similar, problem. I brought over a working project from xcode on the mac to visual studio 2015 on windows 10. The video plays fine in debug and release on windows. Since i wanted to rename the project, I created a new project using the project generator, than copied over the code and the data folder from the working project. In the new project, i see the video in debug, but not in release.
To make sure it wan’t the video file, I put my video in the videoPlayer example. This ran just fine in debug and release. Than i put the from the videoPlayer example in my new project and it ran fine in debug, but no video in release. Next i created a new project using the project generator, and copied over the videoPlayer example and as you can probably guessed, it ran fine in debug but no video in release.
My working hypothesis is that project generator for vs is doing something that interferes with the video playing in release.
all of this because i wanted to rename a project in visual studio, which i still haven’t figured out, but that is a separate thread.

It’s an old thread; Have you guys resolved it? - Just ran into the same issue porting from os to windows. Videos run fine in debug but don’t load in release. My initial guesses are 1) wrong path, or 2) insufficient permissions. What a bum. [UPDATE] I can see that the videos are being loaded and played (codecs are running and my console frame counter is updating fine for each video) - which in turn likely means they are simply not being drawn (or drawn incorrectly). My videos are RGBA btw. [FINAL UPDATE] In my specific case a simple switch of pixel format from RGBA to BGRA solved it… geez.

I can confirm now that switching the pixel mode to BGRA helped me too.

Visual Studio 15, oF 0.10, video player example works both in debug/release but compute shader texture example had trouble in release.