VideoGrabberExample - Apple Mach-o Linker(ld) Errors

Same problem here, using xcode 4.02, MacOS 10.6, Base SDK:4.3.

The most interesting thing is that i can run most of the projects in the iPhoneSpecificExamples folder.

I need to somehow capture video, so i’m trying to run VideoGrabber example and get the following result:

  
  
Apple Mach-O Linker(ld) Error   
  
Undefined symbols for architecture i386:  
  "ofiPhoneVideoGrabber::ofiPhoneVideoGrabber()", referenced from:  
      ofVideoGrabber::initGrabber(int, int, bool)in libofxiPhone_iphonesimulator_Debug.a(ofVideoGrabber.o)  
ld: symbol(s) not found for architecture i386  
collect2: ld returned 1 exit status  
  

When i try to run the _ openCVExample _ i get 42 Apple Mach-O Linker(ld) Errors as mentioned http://forum.openframeworks.cc/index.php/topic,6164.msg29684.html#msg29684"">here.

Even tried the symbols hidden by default option.

Any suggestions?

Regards.

I’m running into the same thing. Did you ever get this resolved?

Same here. Any solution?

I only ran into this when trying to run the videoGrabber example in the simulator, as soon as I moved onto the device itself everything worked fine, which makes perfect sense actually.

I have the same problem compiling the videoGrabberExample for iOS, with OF0.071.
ofiPhoneVideoGrabber::ofiPhoneVideoGrabber is supposed to be implemented in libs\openFrameworks\video\ofiPhoneVideoGrabber.mm.
At the first line there is :
#if defined __arm__
it should be defined ??

I tried to use directly the AVFoundationVideoGrabber class, but it’s declared in two files :
\addons\ofxiPhone\src\AVFoundationVideoGrabber.h
\libs\openFrameworks\video\ofiPhoneVideoGrabber.h

and the second one is taken, and I have the error “Variable has incomplete type” (the class name only is declared).

I’m using OF a lot on Mac and Windows, but I’m new on iOS.
Help !

@joshua : what do you mean by “moved onto the device” ? don’t have to compile first ??

same problem with OF0.07
I have iOS 5.1 base SDK

ok, silly question
now I’ve got a iOS licence, and everything all right
I didn’t understand joshua’s answer, now it’s clear : you can’t have a videoGragger in the simulator
thanks