vc2005 sp1 redist not working with of0.05

Hi,

I’ve always used the vcredist when deploying my compiled (vc2005sp1) of apps on other computers and it has been working perfect. Since of005 that seems not to work anymore. I tried compiling the advancedGraphicsExample from of004 & of005 on one computer and deploying it on another, of004 works, of005 doesnt. Is there any new dependencies in of005?

I’ve been through the topics about redistribution and tried the manifest guide here: http://forum.openframeworks.cc/t/a-of-program-can-be-standalone/249/0 (but this is for vc2008 only, right?) But since i dont need to do this for older of apps i figured it would be something else. Any ideas?

thanks
/cj

(but this is for vc2008 only, right?)

I’ve never done, and I could be very wrong, it but I thought the message I quoted about manifests related to 2005 only…

  • zach

between 0.04 and 0.05, we’ve changes our use of windows (using windows mean_and_lean) to avoid conflicts with some addons (specifically, winsock collision). That changed our usage of glut. I wonder if those changes are making it problematic?

– zach

Hm, I had something similar, but only while doing debug builds, a release build would run correctly, give it a go if you haven’t already tried it.

i had trouble with this too — i tried creating a merge module and an installation to no avail. then i looked at the manifest created by VS and found that there were references to both CRT and DebugCRT, even when i was compiling for Release… weird!

i was also getting a warning about rtaudio on compille, so, since i’m not using audio for this project, i went ahead and commented out all audio references, includes, and libraries. then, lo and behold, it compiled fine and it also worked on my other machine which does not have VS installed on it.

therefore: it looks to me like rtaudio was compiled in debug mode when it was included in 0.05!