v0.9.2 ARMv7 on RPI2 Fails to Compile

I note that the getting started instructions for ARMv7 say to download ARMv6 version of OpenFrameworks. You have the wrong instructions in the ARMv7 download area. Also, OpenFrameworks fails to compile.
Here is the error message I get when I try to compile:

pi@raspberrypi:~/openFrameworks $ make Release -C /home/pi/openFrameworks/libs/openFrameworksCompiled/project
make: Entering directory ‘/home/pi/openFrameworks/libs/openFrameworksCompiled/project’
makefileCommon/config.shared.mk:217: *** This package doesn’t support your platform, probably you downloaded the wrong package?. Stop.
make: Leaving directory ‘/home/pi/openFrameworks/libs/openFrameworksCompiled/project’


I’ve compiled succesfully ARMv7 on rPi2 with this MAKEFLAGS


However, I don’t know if this is a good thing to do so I turned to Archlinux, there’s a preety good getting started for that

Getting your Raspberry Pi 2 B ready for openFrameworks

Have fun ! :smile:

armv7 is not supported in raspbian any more, although the raspberry pi 2 is armv7 raspbian is compiled for armv6 and mixing architectures in the binaries was problematic. if you want to use raspbian you should use armv6 if you want to use armv7 you need to use some other distribution like archlinux as is explained in the docs


I’m having the same issues building for armv6 on raspbian, I’ve tried 0.9.2 and 0.9.0, i’ve tried make IS_RASPBIAN=1 Release and I’ve tried export RPI_ROOT=/ and export GST_VERSION=1.0.

I’m on a fresh install of raspbian on a pi 2 model B

the error I get now is

make[1]: /opt/cross/bin/arm-linux-gnueabihf-g++: Command not found
makefileCommon/compile.core.mk:239: recipe for target ‘/home/rich/openFrameworks/libs/openFrameworksCompiled/lib/linuxarmv6l/obj/Release/libs/openFrameworks/gl/ofGLRenderer.o’ failed
make[1]: *** [/home/rich/openFrameworks/libs/openFrameworksCompiled/lib/linuxarmv6l/obj/Release/libs/openFrameworks/gl/ofGLRenderer.o] Error 127

fixed it by adding CROSS_COMPILING=0 to make