Using openCV Addon in 007 in Codeblocks gives me errors.

Hello!
Im using the install.xml file using the addon for CodeBlocks 10.05 but I get this error:
[tt]mingw32-g++.exe: …/…/…/addons/ofxOpenCv/libs/opencv/lib/win32/libcxcore.a: No such file or directory
mingw32-g++.exe: …/…/…/addons/ofxOpenCv/libs/opencv/lib/win32/libcv.a: No such file or directory[/tt]

And of course, neither that directory nor those files are there, but they are added because of the install.xml file.

  
<lib os="win32" compiler="codeblocks">../../../addons/ofxOpenCv/libs/opencv/lib/win32/libcv.a</lib>  
<lib os="win32" compiler="codeblocks">../../../addons/ofxOpenCv/libs/opencv/lib/win32/libcxcore.a</lib>  

But the openCV example compiles perfectly fine without those files.
Can anyone help?
Thank you? =D

it looks like maybe the path is misnamed, try win_cb/ instead of win32/

Thanks for the reply Kyle. I had tried this but it did not work since the files mentioned are not there either. They used to be there in the 062 version of oF but I tried those too and they give me more compilation error.
=)

they’re definitely in github. https://github.com/openframeworks/openFrameworks/tree/master/addons/ofxOpenCv/libs/opencv/lib/win-cb

if they’re not in the download, that’s a mistake. try downloading from github if possible: https://github.com/openframeworks/openFrameworks/zipball/master (beware: it’s a much larger download than usual because it contains all the OSes)

I will try what you mention. Thank you! :stuck_out_tongue:

i think the problem is the xml file could be outdated. The library files don’t have those names anymore. There are now much more files now and they need to be included in a specific order trying to set them manually can be hard. If the openCV example is working then the files are there for sure, try making a copy of the opencv example.

Hello Arturo:
Yes I tried that too. The problem for me is that my project uses both ofxAssimpModelLoader and ofxOpenCv. Since I know ofxOpenCv more than the other I settled for starting my project based on the Assimp example, then importing the other addon using the install.xml. It didn’t work so then I tried it the other way around and it didn’t work either.
I think both of those addons have such problems with “outdated install.xml files”.
Since my project uses both very deeply, I cannot test one or the other separately to give a better answer.

Also, can I ask how can I use the install.xml file in Visual C++ 2010 Express? because I think I got my project working there now.
Thanks =)

actually the install.xml does nothing, it’s just instructions on how to add the addons to projects. How were you ‘using’ it in codeblocks?

I’m using the install.xml files with the Code::Blocks plugin for openFrameworks:
http://forum.openframeworks.cc/t/code::blocks-plugin-for-openframeworks-in-progress/2389/0

I never had any problems using it with 0062 and I also tried adding them manually, but as I mentioned the 007 install.xml files have outdated references.

ah ok, no the new plugin actually doesn’t use the xml files. Have you installed the new version from scripts/win_cb/wizard?

and no there’s nothing similar for visual studio

Never, so I’ll try it right now.

I cannot get it to work. I have a Windows 7 x64 pc and installed Python27 in x86 and the other programs.
I didn’t get much far but this looks very promising! =D
Any guidance would be great!
Thanks! :stuck_out_tongue:

:frowning:
I get nothing out of the Wizard besides a addons.make file.
Has anyone had that problem?

I use Windows x64 and Code Blocks 32 bit 10.05
I installed:
python-2.7.2.msi
lxml-2.3.win32-py2.7.exe
argparse-1.1.win32.msi

actually the wizard uses the createProjects.py script in scripts/win_cb You can try using the script directly. Just add the addons you want to use in the addons.make file and run the script passing as parameter the path to the project you want to add addons to. That should update the codeblocks project

nice!
:stuck_out_tongue:
Works great!
I got it working like you mention. I’ll try and fix the Wizard later.

By the way, what happens if I want to add another addon that doesn’t usually come with openF?

just put it in the addons folder, add it in your addons.make and rerun the script

Perfect!
:stuck_out_tongue:
This definitely makes my workflow faster! :stuck_out_tongue: thanks!

I added ofxBox2d and ofxMSKinect just to see if it worked and I havent gotten it work.
I get a weird error when I do what you just told me:

[tt]error ofxBox2dofxMSKinectofxXmlSettings in addons.make not found[/tt]

Any ideas? =)

ahhhh!
I think its the windows problem of next line character :stuck_out_tongue: sorry!

do you have them in one line each?

  
ofxBox2dofxMSKinectofxXmlSettings  
ofxOpenCv  
ofxAssimpModelLoader  
  

Its the next line character. Notepad shows me the line like this:

  
ofxBox2dofxMSKinectofxXmlSettingsofxOpenCvofxAssimpModelLoader  
  
  

There… fixed it… Thank you! :smiley: