Using Cocoa/Obj-C produces more than a thousand errors!

I’d like to use some Obj-C in an OpenFrameworks project. I tried to use ofxCocoa, but ran into some trouble, but I don’t really need Cocoa GUI stuff anyway so I thought it would be simpler to just have the project work as Objective-C++. I changed the main.cpp and testApp.cpp to main.mm and testApp.mm and everything compiles fine. However, if I try to include <Cocoa/Cocoa.h> or the header file for an Objective-C class, I wind up with more than a thousand errors. I suspect there is probably a project/compiler setting that I need to flip the switch on or something. Can anyone shed some light on this situation for me?

-Aaron

I had the same problem. I was able to get the messages down to a few but I was never able to get it to compile. I was able to fix the issues with FreeImage.h but there are a number of gl/glut/glew/glee/glext issues that are beyond me.

I tried with 006, 0061, 0062, and today’s git repo, all without success. I would love to get this library running.