(urgent!) Installing libgl1-mesa-dev-hwe-18.04

ubuntu:18.04.02
gcc:gcc 7.3.0
openFrameworks: v0.10.1

command sudo ./install_dependencies.sh

error:
Installing libgl1-mesa-dev-hwe-18.04
E: Unable to locate package libgl1-mesa-dev-hwe-18.04
E: Couldn’t find any package by glob ‘libgl1-mesa-dev-hwe-18.04’
E: Couldn’t find any package by regex ‘libgl1-mesa-dev-hwe-18.04’
error installing libgl1-mesa-dev-hwe-18.04
Reading package lists… Building dependency tree… Reading state information…
this seems an error with your distribution repositories but you can also
report an issue in the openFrameworks github: http://github.com/openframeworks/openFrameworks/issues

Please help,More urgent

Hello, is there anyone?

Hi,

Did you look at this post?

I have 16.04 and I ran into the same type of issues so I think pressing no would solve you problem probably.

Hope it helps.

++

2 Likes

Uh huh. Thank you

There is no such package “libgl1-mesa-dev-hwe-18.04”. There is a package called “libgl1-mesa-dev” however, so if you edit the script and change it to that, it should run. I’m pretty sure if you compile from the nightlies or git master this is fixed.

4 Likes

Perfect answer
It solved for me (ubuntu 18.04 / oF 9.8)
Then I got this issue but @arturo got the other answer.

Thanks to community

1 Like