Unresolved external error when trying to update in the Project Generator

Whenever I open an existing project with the Project Generator it results in a compilation error:

Booting a new project in the Project Generator and running it doesn’t result in an error, only updating an existing one. I’m using VSC2019 v16.11.9, project generator v0.30.0.

Quite new to OF and digging it so far, and would very much like support on the matter!

to clarify, you are using the project generator to update an existing project?
can you try cleaning the solution and rebuilding?
also can you check the target, try 64bit if it’s set to 32 bit?

1 Like

None worked, but I managed to find a solution!
Your suggestions got me fiddling with the solution settings, then I selected “Retarget Solution”:

After confirming the upgrade the solution worked like a charm!
This fix probably fits for my specific versions/settings, but could use a share since I didn’t find an answer to this nowhere online.

Thanks for the guidance Zach!