Unicap problems with two capture devices

I am using Ubuntu 8.10 and of_preRelease_v0.06_linux_cb_FAT.
The version file of unicap says:

  
#ifndef __UNICAP_VERSION_H__  
#define __UNICAP_VERSION_H__  
  
#define UNICAP_MAJOR_VERSION 0  
#define UNICAP_MINOR_VERSION 9  
#define UNICAP_MICRO_VERSION 1  
...  

Now I am trying to run two capture devices at the same time.

  
class testApp : public ofSimpleApp{  
	public:  
		void setup(){  
                   vidGrabber1.listDevices();  
                   vidGrabber1.setDeviceID(0);  
                   vidGrabber1.initGrabber(640,480);  
  
                   vidGrabber2.setDeviceID(1);  
                   vidGrabber2.initGrabber(640,480);  
                }  
		void update(){  
                   vidGrabber1.grabFrame();  
                   vidGrabber2.grabFrame();  
                }  
		void draw(){  
                   vidGrabber1.draw(  0,100);  
                   vidGrabber2.draw(645,100);  
                }  
  
		ofVideoGrabber vidGrabber1;  
		ofVideoGrabber vidGrabber2;  
};  

The first will be shown, but the second not. It is possible to use one device at a time, but not together. After I init the second grabber it says:

  
...   
Unicap: error starting capture  

Do somebody see a way to solve this Problem? What do I wrong? Is it possible to use two capture devices at the same time?

(Under windows without unicap it works fine!)

,Seven

hi seven

in principle it should work with two devices, i’ve tried with 2 different devices and it worked, but someone report sometime ago about not being able to use 2 firewire devices at the same time as they reported the same id. but it seems to be some kind of linux problem.

what kind of devices are you using?

also can you try with this version?

http://www.openframeworks.cc/files/006/-…-FAT.tar.gz

in setup add also this:

  
ofSetLogLevel(OF_VERBOSE);  

arturo

The two device are exactly the same tv-cards with the BT878 chip.

I will have a look for the id, maybe you are right they reported the same id to unicap.
But is there a way to fix it. Was there a solution for the 2 firewire devices?

I also will try your OF version.

Thanks arturo!

,Seven

there wasn’t any solution for the firewire devices that we could find, it seemed a really low level problem. In the case of usb is strange, can you try with ucview and see if both of them are reported?

We use tv capture cards with svideo input.

Ok I tried the new version, but it did not help.
In another post I read that maybe an older version of unicap will help. I tried the unicap version from of_005_linux_cb and it helped.
With this old 0.2.18 unicap version it all works with both two devices at the same time!

,Seven

Hey Seven

thanks for doing all this testing is being super useful.

can you test with this version, i think some compiling flag for unicap that was needed before isn’t needed anymore and is what it’s making it not work with more than 1 device. at least for me is working now.

http://65.111.166.199/openframeworks/unicaplib.tar.bz2

just delete libs/unicap/lib and uncompress the contents in libs/unicap

thanks