Undefined Symbols and other linking problems

Hey guys,
I just downloaded the pre-release and am trying to get the demo apps to compile on my macbook(core duo). I ran the _INTEL CLICK (& TOO), and when I opened up projects and tried to compile I got a “Table of contents error” on Freetype.a I used ranlib to update the table of contents on freetype.a but now I’m getting "

/usr/bin/ld: Undefined symbols:  
collect2: ld returned 1 exit status  

This is broaches the limits of my knowledge at the moment (never played with xcode before but have done a fair amount of programming, some c++) I hope you can help.


Hmmm I am looking into it.

It seems to be something with g++ not explicitly being declared.

Are you using the latest Xcode?

A couple other things you can try - in the the Build menu of Xcode select ‘clean all’ and then try to build it again. This gets rid of all the old code and builds it fresh.

Also if you go to Project->Edit Project Settings make sure that the architecture is set as Intel and not PPC and Instruction scheduling doesn’t say anything like microtune PowerPC G4.

I still don’t really understand why you are getting this error as another member used it with his macbook just fine. Maybe you need the latest Xcode (2.4.1)

Let me know!!!

Ah, I was totally using Xcode 2.2…duh! Just upgraded, everything is working great. Now I need to refresh my C++…