Undefined reference errors in qt creator

I tested OF in Terminal and it works fine, but when I try to connect it to Qt Creator I get a lot of these errors (32,000 of them) saying “undefined reference”

I’m not sure if this is related but Qt Creator is also grayed out when I open the Project Generator. Not sure if the install_template.sh script actually worked or not or if there is some other issue.

Any help would be much appreciated!

For anyone searching this in the future, there was an issue with trying different versions of Qt Creator and the uninstall via MaintenanceTools not actually deleting all of the data. I ran the following commands to get rid of all of the data and then reinstalled the standalone 4.0.1 and it worked!

sudo apt-get remove --auto-remove qtcreator

sudo apt-get purge --auto-remove qtcreator

Exactly the same problem here. I used your commands to completely remove QTCreator but since I have downloaded a few versions from their website and not through APT it didn’t do anything.

It looks like there is a wrong path somewhere in the OF code. The compiler is looking for all sorts of Poco library files directly in my home folder.

/home/XXX/openFrameworks/libs/poco/lib/linux64/libPocoNetSSL.a(ConsoleCertificateHandler.o):-1: In function Poco::Net::ConsoleCertificateHandler::onInvalidCertificate(void const*, Poco::Net::VerificationErrorArgs&)':

The file mentioned above is present. Then it starts looking for files in my home folder:

/home/XXX/ConsoleCertificateHandler.cpp:-1: error: undefined reference tostd::cout’`

...

and so on. 37.000+ times.

Also the newest version of QTCreator (4.4 at the moment) does not work at all with OF. I run QTcreator 4.1.0 on Debian Jessie 8 (Linux 3.16) with KDE desktop.

1 Like