Unable to set up QT Creator on Ubuntu 64bit machine

Hey guys! Thanks for an amazing framework. I am still getting started and the curve is a bit steep.
I have managed to make and make run almost all examples but even after two sleepless nights trying to fiddle with IDEs like CodeBlocks and QT Creator. I have not been able to compile even a single project of my own.

I dont see any files in QT Creator like .c or .h files , only a .qbs file when i choose the open existing openframeworks project. Its not like the video shown on the page in documentation.

Also when i build, i get a stack size error.

Requesting some much needed help :worried:

Rohit

hello,

see “issues” tab (bottom left) for errors.
I guess you have “RangeError: Maximum call stack size exceeded.” error.

openFrameworks doesn’t work with Qtcreator 4 yet.
You need to download and install Qtcreator 3.6.1

http://download.qt.io/official_releases/qtcreator/3.6/3.6.1/

Hi !

Thanks a lot for the quick reply. I am still unable to get it to work. As you suggested i have downloaded 3.6.1
What should i include in OF path? The exact path to the downloaded OF Directory?

Also, i did ran make on a few projects. I hope that is not making things worse?

Thanks a ton :slight_smile:

the OF path should be the directory you extracted OF to.
Qtcreator will detect it when you are in it. It won’t allow you to continue otherwise.

Run make won’t mess anything at all.

Did you run every linux script ?

Did you import project with OF template under Qtcreator ?

Hi Gallo,

the OF path should be the directory you extracted OF to.
Qtcreator will detect it when you are in it. It won’t allow you to continue otherwise.

Run make won’t mess anything at all. - Thanks!

Did you run every linux script ? Yes! As it was mentioned in documentation.

Did you import project with OF template under Qtcreator ? Yes!

My flow is as shown.

<img

Thanks! Its giving an empty profile.
I did run that shell script for QT Creator

Thanks in advance!

Rohit

did you have a look at your project settings ?
What are your profiles / kits look like ?

see “projects” tab on the left column

Thanks again Gallo for the reply.

I found some issues with the kits. There was no compiler installed. Things are not compiling still. I get the following error.

While i waited for things to be figured out. I borrowed a windows 7 32 bit machine. It was a disaster. Followed all the steps and in the end the QT Creator 3.6.1 did not open due to missing DLLs , 3.5.1 installed but kept on crashing and 4.0.3 does not even execute.

Then went the VS way. They need a “Bindows 10” to run.

Atleast, i could now see the files here !

Please suggest what more can be done.

Anxiously waiting for some support

Rohit

try to clean up the project :

"compile->clean all"

then re-scan

"compile->restart qbs"

then re-build

you need gcc 4.9 or more to use C++14. Check in terminal with :

gcc --version

but i think you should be good. Strange that Qtcreator doesn’t setup accordingly…

if the problem persists, you should configure qtcreator (or openFrameworks template ?) probably somewhere in a .qbs file, to use C++11 :

-std=gnu++11

look into your openFrameworks directory for the file :

libs/openFrameworksCompiled/project/qtcreator/modules/of/of.qbs

there you should find

//cpp.cxxLanguageVersion: "c++14"
1 Like

Wohooo ! Thanks a lot !

Apparently it turns out my gcc version was 4.8 !
So upgraded it to 4.9 and changes the alternatives to use it by default.

Will document this fiasco in a post on my blog. :smiley:

Thanks a lot !!

great.
have a nice coding :wink: