Unable to load Info.plist exceptions (eGPUOverrides)

After upgraded to mojave and xcode10, there were problems building examples.

So I followed just like the other topic so I removed i386 and -framework Quicktime in CoreOF.xcconfig.

However, another problem has occurred and Unable to load Info.plist exceptions (eGPUOverrides) message keeps printing.

25

Is there anything i should do else?

I’m not sure what that warning is, but I think it’s harmless (from what I’ve seen googling it)

Does the app run?

but the app does not work… nothing is shown on the screen

nope. no result is shown. just the window with nothing

Try to edit the openFrameworks-Info.plist file and add a new field to it. Xcode will give you all the available options for this new field name. is there anything that says eGPU?

i just looked up the file with xcode, but there is nothing related to eGPU.

which example are you running?

I tried particlesExample in math and meshFromCameraExample in 3d.

I think I have the same issue as you. I managed to get everything working (including 3dprimitives by adding a string to allow for camera usage in the Info.plist) only to get build succeeded but a blank screen app. Until I moved the app window around…

This is the case for all the examples. Wondered if you tried this and if not, does anyone know why it’s happening to me???

this white window thing seems to be a bug in GLFW with mojave. it doesn’t appear when compiling w/ Xcode 9.4.1 but it does with Xcode 10. here’s a fix:

I’ve been experimenting with Xcode 10 mojave and taking notes here:


there’s alot of weirdness to figure out…

@NattyTheHill Actually I did same thing just like you, and I thought the problem was solved. But, too many bugs occurred with other examples and even with my own code. So I downgraded xcode to 9.4.1, but in case of meshFromCamera example, webcam does not turn on even though I added camera usage option… So, seems I should have not upgraded to mojave…

@JinyongSuh – one note is that with 9.4.1 & mojave the plist seems to be not loading properly from what I’ve seen – I’ve found if you run the app outside of Xcode, by double clicking, it works. I’m not 100% sure why that is.

I personally think the best solution at the moment on mojave is xcode10 + legacy compile + window move hack. for legacy build system you can do:

Xcode / File / Workspace Settings / Build system / select “Legacy Build System”

thanks @zach. I checked that it works ok in 9.4.1 when run outside! So now, I would follow your recommendation and wait for the updates!

This happened to me on mojave and xcode 10 when I call a function to load a file from local resource in wkwebview. When I comment the function call … app run and message disappear.

Don’t know if this will be helpful but i found something because i am dealing with a similar issue on a different project.

https://developer.apple.com/documentation/avfoundation/cameras_and_media_capture/requesting_authorization_for_media_capture_on_macos?language=objc

I also get this error when running most of the examples. In most cases I don’t see any issue.

But in slowFastRenderingExample I don’t notice any difference in performance between the 3 modes. Mode 3 is supposed to be must faster than mode 1 and yet I always get the same framerate. Can the warning be the cause for this?

I tried adding several of the privacy keys to openFrameworks-Info.plist to no avail.

Has anyone found a solution for this?

Thanks in advance,
Nuno

Has this issue solved? I still get the same error message even changing the details in Project Setup as @zach mentioned above.