unable to compile

Hello world,

I cannot compile any of the beginner example files. When I Build and Compile I get the following error:

Unable to find Mach task port for process-id 670: (os/kern) failure (0x5).

…not sure what to make of it and found no documentation of it on the boards.

Little help?


curious --maybe you need a reinstall of xcode?


what version of xcode are you using?

  • zach

Just reinstalled, to no avail. Same error… hoping I don’t have to do something drastic like reinstall Snow leopard. Any other guesses?

Much thanks.

what version of OSX and xcode do you have?

  • zach

I have xcode 3.2.2 and osx 10.6.4.

Right, I have xcode 3.2.2 and osx 10.6.4.

hmm. I’m afraid I don’t have many ideas. some thoughts:

a) did you install developer tools as the same user as you are using now?
b) do you have some permissions issues on the hard drive (ie, is it a computer that has folders locked down)

my suspicion is that it’s a permission thing, as I’ve seen some funky errors when you run xcode under a locked down machine.

Beyond that, I’m not sure what else to suggest, besides repairing disk permissions and / or installing osx again:


hope this helps, and good luck

I am unable to successfully build anything. I get 344 errors when I try to do so. I have OSX 10.6.4 and Xcode 3.2

I tried various configuerations for the project edit settings but it only got worse as I had the errors sky rocket. It is set to GCC 4.2 to compile as well. Please help!

have you moved or altered the contents of the OF folder?
can you try on another machine?

take care