Ubuntu project generator build error message

this is the end portion of the output from compilePG.sh (error message is the last line):

Linking bin/projectGeneratorSimple_debug for linux64
g++ -o bin/projectGeneratorSimple_debug obj/linux64/Debug/src/testApp.o obj/linux64/Debug/src/main.o obj/linux64/Debug/src/pugixmlLib/src/pugixml.o obj/linux64/Debug/src/projects/visualStudioProject.o obj/linux64/Debug/src/projects/baseProject.o obj/linux64/Debug/src/projects/CBLinuxProject.o obj/linux64/Debug/src/projects/xcodeProject.o obj/linux64/Debug/src/projects/CBWinProject.o obj/linux64/Debug/src/utils/Utils.o obj/linux64/Debug/src/utils/ofAppNoWindow.o obj/linux64/Debug/src/addons/ofAddon.o …/…/…/addons/obj/linux64/Debug/ofxGui/src/ofxPanel.o …/…/…/addons/obj/linux64/Debug/ofxGui/src/ofxBaseGui.o …/…/…/addons/obj/linux64/Debug/ofxGui/src/ofxGuiGroup.o …/…/…/addons/obj/linux64/Debug/ofxGui/src/ofxLabel.o …/…/…/addons/obj/linux64/Debug/ofxGui/src/ofxToggle.o …/…/…/addons/obj/linux64/Debug/ofxGui/src/ofxSliderGroup.o …/…/…/addons/obj/linux64/Debug/ofxGui/src/ofxSlider.o …/…/…/addons/obj/linux64/Debug/ofxGui/src/ofxButton.o …/…/…/addons/obj/linux64/Debug/ofxXmlSettings/src/ofxXmlSettings.o …/…/…/addons/obj/linux64/Debug/ofxXmlSettings/libs/tinyxmlparser.o …/…/…/addons/obj/linux64/Debug/ofxXmlSettings/libs/tinyxmlerror.o …/…/…/addons/obj/linux64/Debug/ofxXmlSettings/libs/tinyxml.o …/…/…/libs/openFrameworksCompiled/lib/linux64/libopenFrameworksDebug.a -Wl,-rpath=./libs:./bin/libs -Wl,–as-needed -Wl,–gc-sections -L…/…/…/libs/fmodex/lib/linux64/ -lfmodex …/…/…/libs/glfw/lib/linux64/libglfw3.a …/…/…/libs/kiss/lib/linux64/libkiss.a …/…/…/libs/rtAudio/lib/linux64/libRtAudio.a …/…/…/libs/tess2/lib/linux64/libtess2.a …/…/…/libs/poco/lib/linux64/libPocoNet.a …/…/…/libs/poco/lib/linux64/libPocoXML.a …/…/…/libs/poco/lib/linux64/libPocoUtil.a …/…/…/libs/poco/lib/linux64/libPocoFoundation.a …/…/…/libs/poco/lib/linux64/libPocoNetSSL.a …/…/…/libs/poco/lib/linux64/libPocoNet.a …/…/…/libs/poco/lib/linux64/libPocoCrypto.a …/…/…/libs/poco/lib/linux64/libPocoUtil.a …/…/…/libs/poco/lib/linux64/libPocoXML.a …/…/…/libs/poco/lib/linux64/libPocoFoundation.a -lz -lgstapp-1.0 -lgstvideo-1.0 -lgstbase-1.0 -lgstreamer-1.0 -ludev -lsndfile -lopenal -lportaudio -lm -lpthread -lssl -lcrypto -lpulse-simple -lpulse -lasound -lGLU -lGL -lGLEW -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgio-2.0 -lpangoft2-1.0 -lpangocairo-1.0 -lgdk_pixbuf-2.0 -lcairo -lpango-1.0 -lfreetype -lfontconfig -lgobject-2.0 -lglib-2.0 -lmpg123 -lglut -lX11 -lXrandr -lXxf86vm -lXi -lfreeimage
cp -r …/…/…/export/linux64/* bin/

 compiling done
 to launch the application

 cd bin
 ./projectGeneratorSimple_debug
 
 - or -
 
 make RunDebug

mv: cannot stat ‘…/…/…/projectGenerator/projectGeneratorSimple’: No such file or directory

Pretty sure that’s been fixed on github. The next version will have it sorted. It’s compiling the Debug version of the Project Generator and then trying to copy the Release version. If you open up the script you should be able to fix it if you hunt around.

OK, thanks! I think I did download from the .cc site, rather than github. Now I have that guidance, I’m sure I can fix it. Just wanted to do my bit, so to speak, by reporting it.

correction: I don’t know how to fix it. I’m new to bash scripts (I’m a wizard with .bat files, but… yeah…) … anyone recommend a good Unix script reference/tutorial? I can do a diff on my version & the latest git version, but that can only get me so far, in terms of learning shell scripting.

Check out the latest release - it’s fixed there I believe;
http://openframeworks.cc/download/
https://raw.github.com/openframeworks/openFrameworks/0.8.1/CHANGELOG.md