Ubuntu 16.04 oF 0.9.3 examples not running

hello…
fresh install of ubuntu 16.04…
installed dependencies
ran compileOF.sh (required that i run as sudo, i’ve never seen that before)
. this completed without errors.

i can compile the polygonExample with make (requires sudo as well)
when i make run i get the following error:

Segmentation fault (core dumped) /home/ulrstudio/of_v0.9.3_linux64_release/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:169: recipe for target 'run' failed make: *** [run] Error 139

this seems to be happening with all examples. I tried importing them through the PG (which compiled and runs fine).

GCC version: 5.3.1

do i need to try GCC 4.9?

just tried with gcc-4.9 and got the same errors.

Can you post the full output? I think there should be more Info.

That you require sudo is strange. What happens without?

sure…

GNU Make 4.1
Built for x86_64-pc-linux-gnu
Copyright (C) 1988-2014 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.
Reading makefiles...
HOST_OS=Linux
checking pkg-config libraries:   cairo zlib gstreamer-app-1.0 gstreamer-1.0 gstreamer-video-1.0 gstreamer-base-1.0 libudev freetype2 fontconfig sndfile openal openssl libpulse-simple alsa gl glu glew gtk+-3.0 libmpg123 
Updating goal targets....
 File 'run' does not exist.
Must remake target 'run'.
Segmentation fault (core dumped)
/home/xxx/of_v0.9.3_linux64_release/libs/openFrameworksCompiled/project/makefileCommon/compile.project.mk:169: recipe for target 'run' failed
make: *** [run] Error 139




also to note… this was working on 14.04; same machine.

@underdoeg I started from a new tar of oF after moving to gcc-4.9, this time around i no longer need sudo. i can’t remember what steps i took differently.

another note… trying to use the projectGenerator i also get segmentation fault:

Command failed: /bin/sh -c "projectGenerator"  -o"/home/ulrstudio/of_v0.9.3_linux64_release" -a" " -p"linux64" "/home/ulrstudio/of_v0.9.3_linux64_release/examples/graphics/graphicsExample"
Segmentation fault (core dumped)

i’m going to close this… i did a clean install of 16.04, clean install of oF and now it’s working. i wonder if it has something to do with nvidia drivers. with this install i have not yet installed the nvidia proprietary drivers, still using nouveau.