Ubuntu 14.04 troubles with the first compiling

Hello folks,

The install guide says that openframeworks comes uncompiled by default

After running the 3 scripts install_codeblocks install_dependencies and install_codecs (no errors for that step), I tried to run the compileOF.sh on the parent directory and then I got this ->>

makefileCommon/config.shared.mk:185: *** This package doesn’t support your platform, probably you downloaded the wrong package?. Stop.
there has been a problem compiling Debug OF library
please report this problem in the forums
chown: cannot access ‘…/lib/linux64/*’: No such file or directory

Ideas ?

Thanks

What does ‘uname -a’ return on your platform?

Also what version of openFrameworks are you trying to install?

@bakercp thanks for the reply
I’m on the 0.8.3 release and I got this for uname -a >>

Linux kalash2 3.13.0-32-generic #57-Ubuntu SMP Tue Jul 15 03:51:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

Are you on a 64 bits system? (Just making sure…)
I have often had a little trouble installing oF on Ubuntu, but it always worked out.
However with 0.8.3 things worked without a hinch! Thanks oF!

Anyway, have you tried opening a project with Codeblocks and compiling from there?

1 Like

I would make sure you are downloading the 64-bit version of oF and not the 32-bit.

The 64-bit linux version is here:

http://openframeworks.cc/versions/v0.8.3/of_v0.8.3_linux64_release.tar.gz

The 32-bit linux version is here:

http://openframeworks.cc/versions/v0.8.3/of_v0.8.3_linux_release.tar.gz

1 Like

Great news Guys !! I’m getting married … well i meant that OF is now working !
Thanks a lot for your help and let’s get some fun here :smiley: