ubuntu 10.10, install script issues

i’m installing latest of via the scripts on ubuntu 10.10

having the following error:

  
./install_dependencies.sh   
Hit [http://us.archive.ubuntu.com](http://us.archive.ubuntu.com) maverick Release.gpg  
Ign [http://us.archive.ubuntu.com/ubuntu/](http://us.archive.ubuntu.com/ubuntu/) maverick/main Translation-en  
Ign [http://us.archive.ubuntu.com/ubuntu/](http://us.archive.ubuntu.com/ubuntu/) maverick/main Translation-en_US  
Ign [http://us.archive.ubuntu.com/ubuntu/](http://us.archive.ubuntu.com/ubuntu/) maverick/multiverse Translation-en  
Ign [http://us.archive.ubuntu.com/ubuntu/](http://us.archive.ubuntu.com/ubuntu/) maverick/multiverse Translation-en_US  
Ign [http://us.archive.ubuntu.com/ubuntu/](http://us.archive.ubuntu.com/ubuntu/) maverick/restricted Translation-en  
Ign [http://us.archive.ubuntu.com/ubuntu/](http://us.archive.ubuntu.com/ubuntu/) maverick/restricted Translation-en_US  
Ign [http://us.archive.ubuntu.com/ubuntu/](http://us.archive.ubuntu.com/ubuntu/) maverick/universe Translation-en  
Ign [http://us.archive.ubuntu.com/ubuntu/](http://us.archive.ubuntu.com/ubuntu/) maverick/universe Translation-en_US  
Hit [http://us.archive.ubuntu.com](http://us.archive.ubuntu.com) maverick Release  
Hit [http://us.archive.ubuntu.com](http://us.archive.ubuntu.com) maverick/restricted Sources  
Hit [http://us.archive.ubuntu.com](http://us.archive.ubuntu.com) maverick/multiverse Sources  
Hit [http://us.archive.ubuntu.com](http://us.archive.ubuntu.com) maverick/restricted i386 Packages  
Hit [http://us.archive.ubuntu.com](http://us.archive.ubuntu.com) maverick/universe i386 Packages  
Hit [http://us.archive.ubuntu.com](http://us.archive.ubuntu.com) maverick/main i386 Packages  
Hit [http://us.archive.ubuntu.com](http://us.archive.ubuntu.com) maverick/multiverse i386 Packages  
Reading package lists... Done  
Reading package lists... Done  
Building dependency tree         
Reading state information... Done  
Note, selecting 'libsndfile1-dev' instead of 'libsndfile-dev'  
gstreamer0.10-ffmpeg is already the newest version.  
g++ is already the newest version.  
g++ set to manually installed.  
libavcodec-dev is already the newest version.  
libavformat-dev is already the newest version.  
libavutil-dev is already the newest version.  
libavutil-dev set to manually installed.  
libsndfile1-dev is already the newest version.  
libasound2-dev is already the newest version.  
Some packages could not be installed. This may mean that you have  
requested an impossible situation or if you are using the unstable  
distribution that some required packages have not yet been created  
or been moved out of Incoming.  
The following information may help to resolve the situation:  
  
The following packages have unmet dependencies:  
 libdrm-dev : Depends: libdrm2 (= 2.4.21-1ubuntu2) but 2.4.21-1ubuntu2.1 is to be installed  
              Depends: libdrm-intel1 (= 2.4.21-1ubuntu2) but 2.4.21-1ubuntu2.1 is to be installed  
              Depends: libdrm-radeon1 (= 2.4.21-1ubuntu2) but 2.4.21-1ubuntu2.1 is to be installed  
              Depends: libdrm-nouveau1 (= 2.4.21-1ubuntu2) but 2.4.21-1ubuntu2.1 is to be installed  
 libudev-dev : Depends: libudev0 (= 162-2) but 162-2.1 is to be installed  
E: Broken packages  
Package gstreamer-0.10 was not found in the pkg-config search path.  
Perhaps you should add the directory containing `gstreamer-0.10.pc'  
to the PKG_CONFIG_PATH environment variable  
No package 'gstreamer-0.10' found  
Package gstreamer-video-0.10 was not found in the pkg-config search path.  
Perhaps you should add the directory containing `gstreamer-video-0.10.pc'  
to the PKG_CONFIG_PATH environment variable  
No package 'gstreamer-video-0.10' found  
Package gstreamer-base-0.10 was not found in the pkg-config search path.  
Perhaps you should add the directory containing `gstreamer-base-0.10.pc'  
to the PKG_CONFIG_PATH environment variable  
No package 'gstreamer-base-0.10' found  
Package libudev was not found in the pkg-config search path.  
Perhaps you should add the directory containing `libudev.pc'  
to the PKG_CONFIG_PATH environment variable  
No package 'libudev' found  
compiling object for  ../../../openFrameworks/app/ofAppRunner.cpp  
mkdir -p obj/Debug/openFrameworks/app  
g++ -g3 -Wall -fexceptions -I../../../FreeImage/include -I../../../assimp/include -I../../../assimp/include/Compiler -I../../../cairo/include -I../../../cairo/include/pixman-1 -I../../../cairo/include/cairo -I../../../cairo/include/libpng15 -I../../../fmodex/include -I../../../freetype/include -I../../../freetype/include/freetype2 -I../../../freetype/include/freetype2/freetype -I../../../freetype/include/freetype2/freetype/internal -I../../../freetype/include/freetype2/freetype/internal/services -I../../../freetype/include/freetype2/freetype/config -I../../../glew/include -I../../../glew/include/GL -I../../../kiss/include -I../../../portaudio/include -I../../../rtAudio/include -I../../../tess2/include -I../../../poco/include -I../../../glu/include -I../../../openFrameworks/ -I../../../openFrameworks/app -I../../../openFrameworks/math -I../../../openFrameworks/utils -I../../../openFrameworks/communication -I../../../openFrameworks/3d -I../../../openFrameworks/events -I../../../openFrameworks/types -I../../../openFrameworks/video -I../../../openFrameworks/graphics -I../../../openFrameworks/gl -I../../../openFrameworks/sound  -DOF_USING_MPG123  -MMD -MP -MFobj/Debug/openFrameworks/app/ofAppRunner.d -MTobj/Debug/openFrameworks/app/ofAppRunner.d -o obj/Debug/openFrameworks/app/ofAppRunner.o -c ../../../openFrameworks/app/ofAppRunner.cpp  
In file included from ../../../openFrameworks/utils/ofConstants.h:113,  
                 from ../../../openFrameworks/app/ofAppRunner.h:3,  
                 from ../../../openFrameworks/app/ofAppRunner.cpp:1:  
../../../glew/include/GL/glew.h:1172: fatal error: GL/glu.h: No such file or directory  
compilation terminated.  
make: *** [obj/Debug/openFrameworks/app/ofAppRunner.o] Error 1  
there has been a problem compiling Debug OF library  
please report this problem in the forums  
  

suggestions?

thanks,
dan

it seems like your repository is broken somehow, try deactivating any 3rd party repo so only the official ubuntu versions of the packages are used. Or try to run the apt-get lines in the install_dependencies script manually

thanks for the reply.

as far as i can tell from /etc/apt/sources.list i only have the main,restricted, universe, and multiverse turned on. no additional 3rd party repos. i don’t remember changing any repo settings on this box but my memory leaks.

i ran the apt-get from the dependencies by hand and i think this is the only one that is causing trouble.

  
 sudo apt-get install libdrm-dev  
Reading package lists... Done  
Building dependency tree         
Reading state information... Done  
Some packages could not be installed. This may mean that you have  
requested an impossible situation or if you are using the unstable  
distribution that some required packages have not yet been created  
or been moved out of Incoming.  
The following information may help to resolve the situation:  
  
The following packages have unmet dependencies:  
 libdrm-dev : Depends: libdrm2 (= 2.4.21-1ubuntu2) but 2.4.21-1ubuntu2.1 is to be installed  
              Depends: libdrm-intel1 (= 2.4.21-1ubuntu2) but 2.4.21-1ubuntu2.1 is to be installed  
              Depends: libdrm-radeon1 (= 2.4.21-1ubuntu2) but 2.4.21-1ubuntu2.1 is to be installed  
              Depends: libdrm-nouveau1 (= 2.4.21-1ubuntu2) but 2.4.21-1ubuntu2.1 is to be installed  
E: Broken packages  
  

i can’t say i understand what the end of the error means. it seems that all of the packages mentioned are installed. libdrm2, libdrm-intel1, libdrm-radeon1, libdrm-nouveau1. something about the ubuntu2 vs ubuntu2.1?

any tips?

thanks,
dan

try installing everything but that package

it seems that was not my only problem. dug further, ran more by hand. tried commenting things out and runnin gthings solo.

just removing libdrm-dev, then the error transfer to libudev-dev

and if i comment that one out, i get error with libgl1-mesa-dev, and if i try without that one, i get several
errors as below.

  
Some packages could not be installed. This may mean that you have  
requested an impossible situation or if you are using the unstable  
distribution that some required packages have not yet been created  
or been moved out of Incoming.  
The following information may help to resolve the situation:  
  
The following packages have unmet dependencies:  
 freeglut3-dev : Depends: libgl1-mesa-dev but it is not going to be installed or  
                          libgl-dev  
 libglew1.5-dev : Depends: libgl1-mesa-dev but it is not going to be installed or  
                           libgl-dev  
 libglu1-mesa-dev : Depends: libgl1-mesa-dev but it is not going to be installed or  
                             libgl-dev  
E: Broken packages  
Package libudev was not found in the pkg-config search path.  
Perhaps you should add the directory containing `libudev.pc'  
to the PKG_CONFIG_PATH environment variable  
No package 'libudev' found  
compiling object for  ../../../openFrameworks/app/ofAppRunner.cpp  
mkdir -p obj/Debug/openFrameworks/app  
g++ -g3 -Wall -fexceptions -I../../../FreeImage/include -I../../../assimp/include -I../../../assimp/include/Compiler -I../../../cairo/include -I../../../cairo/include/pixman-1 -I../../../cairo/include/cairo -I../../../cairo/include/libpng15 -I../../../fmodex/include -I../..  
  

keep removing things and trying to compile? or something else? some way to reset the repo stuff?

thanks,
d

try opening synaptic and look for obsolete or local packages. it seems like you’ve installed some packages that are newer versions or something like that.

also look in /etc/apt/sources.list.d or in synaptic software sources to see if you have any additional repo apart from the ubuntu official ones

In this question, the suggestion is to do it with aptitude instead:
http://askubuntu.com/questions/58664/cant-install-package-libglib2-0-dev-because-it-depends-on-some-unknown-version
so sudo aptitude install libdrm-dev could do the trick.

not sure if the aptitude would have worked but i went through package manager gui interface again and found that i had the updates turned off. i thought this was just for the prevention of popup windows telling me to upgrade things.
but it seems that this also nuetered the command line “sudo apt-get update” command…

thanks for your feedback! OF up and running now!