Trouble with noncore addons Xcode 5, of 0.8.0

I have trouble building projects with noncore addons, all the included addons work fine, both running examples and creating new projects using the project generator.

I am on xcode 5.0.2 on 10.9

Basically I am trying to get two addons to compile, ofxTimeline and ofxSyphon.

I have two aims with this post:
some general feedback on troubleshooting when adding noncore addons to a xcode 5 project
specific feedback on getting ofxTimeline and ofxSyphon to work.


ofxTimeline was updated less than a month ago so I was hoping it would work with 0.8.0

I went through the addons required to run ofxTimeline:


If I run the example from within the addons/ofxTextInputField folder I get a ofTypes.h “tr1/memory” file not found (Which is an error I get quite often).

If I create a project using the projectgenerator just with the default source files I get ofxTextInputField.cpp error: out-of-line definition of “set clipboard” does not match any declaration of ofxTextInputField

I updated the addon with a newer fork than what was included with the ofxTimeline and the example compiles and I am able to make a new project using ProjectGenerator

When I try to run the example I get “tr1/memory” file not found

I am able to make a new project using ProjectGenerator

the example compiles and I am able to make a new project using ProjectGenerator

I have no luck compiling any of the examples from within the addons/ofxTimeline folder,
usually getting the tr1/memory file or the error related to the oftextfield.

When I try to create a project with the Projectgenerator, ofxTimeline is strangely enough not included in the new project even if it was checked in the addons section in the ProjectGenerator

I have tried the hints in similar posts about changing the base sdk to 10.8, or just i386 for valid architectures but it doesn´t seem to make a difference.


If I run the basic example from within the addons/ofxSyphon folder it works fine.

If I move the example to examples/addons folder it doesn´t compile, and then I can see in xcode that the content of the src and lib files are not found (files are red)

If I copy the example to my app folder (apps/myApps) I get a lot of mach-o link errors.

If I try to make a new project using the project generator including the ofxSyphon addon and then copy the source files from the basic example I get build errors: Lexical or Preprocessor issue “Syphon/Syphon.h” file not found Lexical or Preprocessor issue “Syphon/Syphon.h” file not found

It seems the ProjectGenerator doesn´t include the complete Syphon libs


for this error, can you try adjusting the sdk targets? set the base sdk to 10.8 for the project (and potentially the project that builds the OF lib). That should help with any tr1 errors (which happens because older xcode project files are referring to an SDK that doesn’t exist).

Hey HC,

I’ve talked to some people who are running Timeline on Xcode 5 & 0 8 So i’m not sure what the issue is beyond some project configuration. Hopefully Zach’s tip helps.

I did already do that for the project in the build settings, without seeing any difference unfortunately.

so this is how it looks like with the textInputExample:

Set like this. I have resolved the problem like images.

1 Like

it seems that setting the c++ language dialect and standard library to your description gets rid of the tr1/memory errors, thanks! Not exactly intuitive though.

The ofxTextInputField still gives me these errors:
/Users/hcg/OpenFrameworks/of_v0.8.0_osx_release/addons/ofxTextInputField/src/ofxTextInputField.cpp:344:25: Out-of-line definition of ‘setClipboard’ does not match any declaration in ‘ofxTextInputField’
/Users/hcg/OpenFrameworks/of_v0.8.0_osx_release/addons/ofxTextInputField/src/ofxTextInputField.cpp:349:27: Out-of-line definition of ‘getClipboard’ does not match any declaration in ‘ofxTextInputField’

This refers to

void ofxTextInputField::setClipboard(string clippy)
glfwSetClipboardString( (GLFWwindow*) ofGetWindowPtr()->getCocoaWindow(), clippy.c_str());

string ofxTextInputField::getClipboard()
const char clip = glfwGetClipboardString((GLFWwindow) ofGetWindowPtr()->getCocoaWindow());
if(clip!=NULL) {
return string(clip);
} else {
return “”;


I solved the ofxSyphon problems. Sloppy homework by me, as I hadn´t understood how to add the syphon.framework. This was well explained in the readme document.

Hi hcgilje,

I run into the same issue switching to OF 0.8 this week. I solved all this problems by adding the addons with Adam Carlucci xcode plugin.

See this thread:

that´s very useful, thanks!

I guess my errors with ofTextInputField is not related to adding the addon to Xcode 5 itself at least, so I will ask a specific question related to that in a more approriate section of the forum.

Check this fork:

I think it will fix your issue, I did the same with ofxTextInputField.



also got it to work with Joshua Noble´s fork of ofTextInputField.