trouble with firmata (oF 0.61)

I have problems getting anything useful out of firmata.
I am running with a baudrate of 57600.

I use the standard firmata example in oF, I have also uploaded standardFirmata to my arduino.
My first attempt was a failure: I got the “Arduino not ready” message.
After searching the forums I saw a tip of adding a delay after the connect message, so I added ofSleepMillis(4000);
and now I am able to connect to the arduino.

The problem is that nothing happens. oF spits out pwm numbers, but nothing happens on pin 11 on the arduino. The analog input value just gives -1, which would indicate an error. The debugger console keeps reporting “trouble reading from port”, and “can´t write to com port”.

Also when I press the mousebutton, the led on pin 13 is supposed to light up, but nothing happens.

I tried changing the baudrate to 19200 on both sides, but that didn´t change anything.

I don´t have a problem communicating with my arduino from oF if I don´t use firmata.

Any clues?


what version of firmata/arduino are you using, also what platform are you in? we tested it for 0061 with the last version and they changed the baud rate again but if you have the same in both side it should work

I am using the standardfirmata that comes with arduino18, and my baudrate is set to 57600 on both sides, and the program is sending stuff to the arduino, the rx led on the arduino is blinking steadily.

I am on a mac, 10.6


If you put a call to printVersion() in the setup do you get anything back? Which board are you using? Also, just out curiousity, have you tried a different firmata, i.e. for example running one from the

I just tried it from max/msp which is the environment I know best, and I have the same issue there. There is serial communication between my computer and the arduino, and I get the version number sent back which is the latest, 2.1. But I am not able to turn on/off anything or receive sensor input (and yes, I have checked that the attached components work).
I am using the diecimila board.

I will look more into it at some point, thanks for the input!


can you possibly jump on the firmata mailing list and see if people there can help you?

I have had problems in the past with the baud rate switch (at some point firmata switched rates)-- there was a bug in firmata.begin() vs firmata.begin(baudRate)… I had recommend hans to use the (baudRate) in the standard firmata code, to be explicit, but the functions inside of firmata library were written differently. I don’t know when exactly that was fixed, but you might see if that is affecting things…

take care,