Trouble setting up QtCreator 4.0.1 with 0.9.4 on Ubuntu 16.04

I’m using:

Ubuntu 16.04.
of 0.9.4
QtCreator 4.1.0

Followed the guide here: http://openframeworks.cc/setup/linux-install/. Can successfully build examples using make, no issues.

I’d first tried 3.5.1, but persistently got this issue wih with the build button greyed out:

/docs-archive/of_v0.9.4_linux64_release/libs/openFrameworksCompiled/project/qtcreator/
ofApp.qbs:33: error: error: Package libmpg123 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libmpg123.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘libmpg123’ found

This lady had the same issue, but unlike her I was already using the 3.5.1. Arturo claimed here that 4.1.0 would now work, so I tried that.

While double-checking after install, install_codecs.sh threw this:

Package gstreamer0.10-plugins-ugly is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package ‘gstreamer0.10-plugins-ugly’ has no installation candidate

install_dependencies.sh ran fine.

This guy solved the same error by removing ~/.config/QtProject. Just like him, a Hello World C++ QBS project buildt and ran fine. So I renamed my ~/.config/QtProject to something else. Upon building:

:-1: error: Unknown or empty profile ‘qtc_Desktop_c9804996’.

This thread had some instructions on dealing with empty profiles. I didn’t know how to make sense of the compilers/kits menu so I didn’t try anything. My Hello World QBS project compiled anyway and ran just fine, and I have GCC 5.4+.

Stumped about what to try next. Any ideas? Can’t wait to get started.

sorry we haven’t updated the guide yet but 0.9.4 or later will work fine with the latest version of qtcreator, 4.1.0

No problem! However I’m still facing the issues I’ve mentioned above using
those exact versions (0.9.4 + 4.1.0), like I’ve mentioned.
I get this error:

/docs-archive/of_v0.9.4_linux64_release/libs/openFrameworksCompiled/project/qtcreator/ofApp.qbs:33: error: error: >Package libmpg123 was not found in the pkg-config search path.
Perhaps you should add the directory containing `libmpg123.pc’
to the PKG_CONFIG_PATH environment variable
No package ‘libmpg123’ found

I’ve run both install_dependencies.sh and install_codecs.sh. libmpg123 wasn’t one of the dependencies.

Same error with 0.9.6 with QtCreator 4.1.0.

Dunno how to proceed.

that package should be installed by install_codecs.sh are you sure you’ve run it and it worked?

This is my output for install_codecs.sh:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Package gstreamer0.10-plugins-ugly is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package ‘gstreamer0.10-plugins-ugly’ has no installation candidate

Thanks for the help!

can you run in a terminal:

apt-cache show -n libgstreamer1.0-dev &> /dev/null; echo $?

apt-cache show -n libgstreamer1.0-dev &> /dev/null; echo $?

gives me

100

huh, thta’s really strange i’m actually getting the same but it’s working for me. i’ll look into it but meanwhile you should be able to fix the problem by running:

sudo apt-get install libmpg123-dev

Btw, if I run

apt-cache show -n libgstreamer1.0-dev &> /dev/null; echo $?

It displays 0 not 100. and if I run:

kovicic@Studio:~$ apt-cache show libgstreamer1.0-dev
Package: libgstreamer1.0-dev
Source: gstreamer1.0
Priority: optional
Section: libdevel
Installed-Size: 3452
Maintainer: Maintainers of GStreamer packages pkg-gstreamer-maintainers@lists.alioth.debian.org
Architecture: amd64
Version: 1.0.4-1~ubuntu12.04.1~ppa1
Recommends: debhelper
Suggests: gstreamer1.0-doc
Depends: libgstreamer1.0-0 (= 1.0.4-1~ubuntu12.04.1~ppa1), libc6-dev | libc-dev, pkg-config, libglib2.0-dev, libc6 (>= 2.2.5), libglib2.0-0 (>= 2.32), gir1.2-gstreamer-1.0 (= 1.0.4-1~ubuntu12.04.1~ppa1)
Filename: pool/main/g/gstreamer1.0/libgstreamer1.0-dev_1.0.4-1~ubuntu12.04.1~ppa1_amd64.deb
Size: 1129810

among another information…

I have installed the last version of libmpq123-dev, however I am facing problems to compile OF, as I stated here in the forum.

Does the 0 mean something is going wrong?. Best!

are you using 16.04 or 12.04?

Crazy, thanks. This got it working. There was another issue with -Wl flags that I sorted out by adding minimumQbsVersion: “1.6” to my .qbs file.

Thank you very much!

12.04, according to these install_dependencies.sh’s lines it isn’t a too older version.

if [ $(expr $MAJOR_VERSION \< 12 ) -eq 1 ]; then
    echo "Your ubuntu version is too old try using an older version of openFrameworks or updating your system"
    exit 1
elif [ $(expr $MAJOR_VERSION \< 13 ) -eq 1 ]; then
    add-apt-repository ppa:ubuntu-toolchain-r/test --yes
    add-apt-repository ppa:gstreamer-developers/ppa --yes
    add-apt-repository ppa:boost-latest/ppa --yes
    CXX_VER=-4.9
    BOOST_VER=1.55

thanks