Trouble running OF examples on Mac OS Lion

Hi everyone!
This is my very very first post on OpenFrameworks! Hooray.
Quite excited about it.

I’ve tried quite a few things to get -something- up’nrunning but no success yet.
I’m on Mac OS Lion (10.7) & got XCode4. I have looked on the internet and there
I found out I had to set my SDK to 10.6, and so I did. But still no luck. It says “Build Successful”
but it doesn’t pop up an application window… It just stops after “Build Successful”.
I’ll be ever so happy to have my first example running (for example, ProjectGenerator).
Who’d like to help me out?


Might be wrong, but seems that your are only bulding not run. You have to run your project after build to view something

[spanish_on] creo que simplemente estas compilando no ejecutando el proyecto, fijate que el boton ponga build and run… yo aun no cambie a la version 4 de xcode asi que no te puedo decir exactamente donde esta el boton… pero esta [/spanish_on]

also make sure you are building your app not just the openframeworks lib

This would be my first guess- make sure the scheme at top left shows the name of the example and not just openFrameworks. Click on it and select the correct one if necessary.

Thanks everyone for the kind response! I tried everything you guys told me but didn’t seem to succeed. Already tried selecting the right scheme and such. I’ll post my screenshot :—)

Notice the “32-bit” in the scheme window.
I’m just using an example that was already in the openframeworks-folder as I downloaded it
straight from their website.

Any other suggestions? I feel we’re getting close! Let’s do this.
Thanks so much for your time.
Kindness, Y.

  • two more additional screens (sorry if it’s getting crowded, but I thought this might clear things up for you guys if you were wondering about my settings)


I’m not familiar with the new project generator but is COMMAND_LINE_ONLY defined in the header? If it is, comment it out and see if it launches. Also do any other examples work?

Thanks for the reply! I’ll try that out in a bit. I have no clue how to launch the other examples (which are located in the examples folder and not the apps-folder) because there’s only a main.h / main.m & one other file in there. Could you give me a brief tutorial of how to set up this example? My starting point is the XCode4 opening window where you can create a new project. (I included a screenshot where you can see what files are available inside the example-dir)

Can you try the download version of openframeworks? What we have on github (what you have there) doesn’t have the examples built for each platform – but the packages here, do:

if you download the OSX version, and navigate to examples/math/noise1dExample you’ll see a xcode project.

The github branch is mostly for developers and folks that want to contribute / track changes happening in the core.

Does that make sense?


Hi Zach! Glad to see you on the forum ;—) hehe. I saw your session at Reasons To Be Creative in New York a while ago and it inspired me to try this out. So thanks for making me curious! I’ll do what you say and try it out.

Do you have any idea what’s wrong with my current downloaded package? Missing files? Or…


Hooray! I did what Zack said and it seems I’m running my very first OF project now :—) I’m so happy!

I was curious if the ProjectGenerator was inside but can’t seem to find it. Is it still under development? For now, we need to copy the “emptyExample” inside the same dir & rename it & start editing/working on it, right?

Looking forward for my next steps! Will toss around with openCV I guess.

I have the same problem and dont see how you fixed it. Any suggestions?

You download the OSX package from
Make a comfortable directory (such as “Documents/Openframeworks/”) and in this folder,
you put the directories from the unzipped file (“apps”, …) Find yourself a nice example
& double click the .xcodeproject file! (blue thumbnail) If you don’t see the .xcode project
file, it seems that you downloaded the openframeworks from github…

I posted my finder structure online, so have a look. (as reference).

Thanks. I had to install “command line tools” in xcode and it is now working.