Thread error and no sketch window

Hi all,

I’m returning to OpenFrameworks after a while, installed the latest build on my macbook (I’m on MacOS Big Sur 11.6), but I get an odd error when running any of the example / my own files.

The build is successful (I’m using xCode) and doesn’t stop, but no sketch window appears and I get this thread error “Thread 1: EXC_BAD_ACCESS (code=2, address=0x7fff2398f3c1)” in “0 addSwizzler” and “10 _dyld_start”.

I’ve tried re-downloading the build and trying the BigSur 11 OS fixes (including this build by Theo Building in macOS 11.0 Big Sur - #40 by theo) but I’m pretty stuck on what is actually wrong and why the sketch window isn’t showing.

If you need any additional info let me know and thanks ya’ll in advance :slight_smile:

Hmm I just tried on a M1 Mac Mini on Big Sur 11.6.
Running one of the examples from the 0.11.2 OF release it all seems to work fine for me.

Which version of Xcode are you on?
Are you using OF 0.11.2?

Turns out I was using an old build of XCode, updated and it’s working perfectly now!

Thanks for your help Theo :slight_smile:

1 Like