Stuck at 60 fps with ofxFenster, OF 0073 and OSX.8 SDK


The framerate is stuck at 60 fps when using ofxFenster with OF 0073 and OSX.8 SDK.
It’s true for every example coming with the addons (and also my projects).
I don’t know if it’s XCode related, Ghost related, …

Of course I’ve tried many things including setVerticalSync(false);

My machine has a GTX670, mountain lion (OSX.8.2) and Xcode 4.4.1

By the way everything is fine with OF 0071 and OSX.6 SDK (the framerate is jupping at 500 fps)

Are you experiencing the same behaviour with ofxFenster ?

have you got ofSetFramerate(60) somewhere?

No of course.

Aaron, do you manage to have more than 60 fps with ofxFenster, OF 0073 and OSX.8 SDK ?

you could set a breakpoint within ofSetFrameRate() and if it gets triggered, try to find out from where…

If I set a ofSetFrameRate(120); it is triggered in the setup function and that’s all.
The framerate is still stuck at 60 fps

possibly related to ?

Thanks Bilderbuchi,

Actually the uncommenting tricks is only for windows machines.

I’m guessing something different in my case : no matter what I’m setting with ofsetframerate, the framerate is always at the frequency of the display.
This is only true when I’m using ofxFenster and OSX.8 SDK and OF003
In any other cases the framerate is what I set or the maximum if I set the vertical sync to false.
I’ve tried many displays at different frequencies and If I have two window on different display (for example one at 60Hz and the other at 50Hz), the framerate is 50 fps (the lowest).
I think that it is related to the hardware.
It seems that ofSetVerticalSync(false) is not broken with OSX.8 and ofxFenster. Without ofxFenster it’s working.
There is also a setFrameRate function in ofxFenster.cpp. I’ve tried to call it but it’s the same.

yeah i know that. the bug report is only about windows machines, but the error could conceivably also effect other machines in other configurations - the observed behaviour is similiar.

Forgot to say that I’ve try it and it’s the same.