starting afresh on codeblocks

I seem to be having to install a c++ ide on different machines all the time and vs2005 express is a pain for this. Now its upgraded to 2008 they’ve hidden 2005 and you have to download a lot of additional installs for it to run anyway.

So now i am looking at codeblocks.

We should definitely make a setup guide for windows so people know to download the right codeblocks from the start etc
http://www.openframeworks.cc/setup

Folloring the steps suggested in the forum:
how-to-install-and-open-devcpp-projects-in-codeblocks

For a new install, only steps a-e should be followed (not a-i as in the readme), if you aren’t coming from dev c++.

My problem is that I installed codeblocks with MinGW, put both sets of additional includes into the right folders (step e). I open the graphics example from the ofw codeblocks windows download. When I try to build it says:

"graphicsExample - release" uses an invalid compiler. Skipping

From a clean install, what am I doing wrong?

When you look at the build options for the project it says compiler is GNU GCC Compiler.

Thanks

Ok I found the solutions, we should write this as part of the setup for new users.

By default codeblocks thinks its in c:\minGW.

So a step should be added for new codeblocks installs (without mingw or devcpp already installed).


Go to settings > compiler & debugger settings > global compiler settings > toolchain executables

Then click auto-detect. It should set this to:
c:\Program Files\CodeBlocks\MingW

did you install into c:/ ? I’ve seen this problem when people install into other drives. also, if other versions of mingw are around – for example, with a devc++ install. finally, seen this when people install CB without mingw.

check settings -> compiler -> toolchain executables and see what it says for mingw, for example mine says:

“C:\Program Files\CodeBlocks\MinGW”

make sure that this is where mingw exists.

hope that’s helpful !

take care,
zach

Hi,

Sorry but I alwys have the problem.

First I have the message “uses invalid compiler”
I fixed in setting the right path for minGW

Second I have that message:

Execution of ‘mingw32-g++.exe -Wno-multichar -g -I…\libs\glu\include -I…\libs\freetype\include -I…\libs\freetype\include\freetype2 -I…\libs\FreeImage\include -I…\libs\quicktime\include -I…\libs\rtAudio\include -I…\libs\fmodex\include -I…\libs\videoInput\include -I…\libs\glee\include -I…\libs\glut\include -I…\libs\openFrameworks -I…\libs\openFrameworks\app -I…\libs\openFrameworks\events -I…\libs\openFrameworks\graphics -I…\libs\openFrameworks\utils -I…\libs\openFrameworks\sound -I…\libs\openFrameworks\video -I…\libs\openFrameworks\communication -I…\libs\poco\include -c E:\PROJETS\_OF\apps\examples\audioOutputExample\src\testApp.cpp -o obj\debug\src\testApp.o’ in ‘E:\PROJETS\_OF\apps\examples\audioOutputExample’ failed.

And i copied the additions.

Some other post talked about changing stdlib.h in cstdlib.h

I really begin,first time I open some OFproject. Can someone help, I really want to work with it after seeing cosmogrammafieldlines, that’s great.

Sebastien

So :smiley:

I Fix it by myself.
I forgot some stuffs, and want to explain because when you begin everything is hard and harder for me in english :

The compiler directory was
C:\Program Files\CodeBlocks\MinGW
and not
C:\Program Files\CodeBlocks\MinGW\bin
and auto-detect find it well indeed.

And I hadn’t to do these changes (stdio.h -> cstdio.h etc.) in ofConstant.h. I just let it as I found in install.

Sorry for this post with french accent, and these beginners questions-answers…

Let’s go !

Wow, it really works !

Thanks to you, that’s great and crazy stuff !