Specify macos target build under qtCreator

hello !

i am using the latest oF 0.10.1 under macOS Mojave and QtCreator 4.8.1

I need to build an app which will run under mac 10.6 (snow leopard).
I tried under XCode 10. I was able to select target build to 10.6 but i end up with a compilation error complaining with a libstdc++ deprecation and need minimum OS version 10.7

I would like to give QtCreator a try but i don’t know how to specify the macOS target build…

The app is pretty simple and straightforward : just a video player using ofVideoPlayer. Only 10 lines of code…

Any clue on this ? is it even possible ?
any help for QtCreator or XCode is appreciated !

thanks a lot